Nginx does not cache long URL

Nginx does not want to cache long URLs. Namely, the query:

1.1.1.1 - - [17/Feb/2012:06:10:21 +0000] "www2.website.com" "GET /zone=1470382351&lp=1468664992&var1=www2V4anothersiteSite&path=/de/live-game/&src=LC&selected_slide_name=1468664992&p_path=/de/live-game/ HTTP/1.0" 302 - "http://www2.website.com/de" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.25) Gecko/20111212 Firefox/3.6.25 ( .NET CLR 3.5.30729)" 131666

Regularly proximedia to Apache, and not cached by ngnikam. Cached everything else like normal.

"proxy_cache_path" /webcache/www2 levels=1:2 keys_zone=www2-cache:8m max_size=1000m inactive=600m;<br> proxy_temp_path /webcache/www2/tmp;

location /shared/css {<br> root /home/nginx/public;<br> expires 1d;<br> #access_log off;<br> }<br> <br / > location /shared/js {<br> root /home/nginx/public;<br> expires 1d;<br> #access_log off;<br> }<br> <br / > location /js {<br> root /home/nginx/public/www2;<br> expires 1d;<br> #access_log off;<br> }<br> <br / > location /skin/default {<br> root /home/nginx/public/www2;<br> expires 3d;<br> #access_log off;<br> }<br> <br / > #location ~ ^.+\.(swf|jpg|jpeg|gif|png|ico|css|js|tmpl)$ {<br> # root /home/nginx/public/www2;<br> # expires 3d;<br> #access_log off;<br> # }<br> <br / > location / {<br> proxy_pass <a href="http://www2;">www2;</a><br> www2 proxy_cache cache;<br> proxy_cache_valid 200 30m;<br> proxy_cache_valid 302 30m;<br> proxy_cache_valid 304 30m;<br> proxy_cache_valid any 10m;<br> }

What can be a rake?
October 8th 19 at 03:18
2 answers
October 8th 19 at 03:20
Try to change the value of proxy_cache_key

For example, I use proxy_cache_key "$request_method|$http_if_none_match|$host|$uri$args"

p.s. by the way, try to add to the log akses '"$upstream_addr" "$upstream_response_time" "$upstream_status" $upstream_cache_status' will be easier to debug caching.
Thanks for the reply, I'll try it.

Read several times the description in the documentation and could not understand what mean this parameter. - Jeffry_Dietrich commented on October 8th 19 at 03:23
October 8th 19 at 03:22
Add something like

server_names_hash_max_size 512;<br> server_names_hash_bucket_size 128;<br>

And then play around with the settings
client_header_buffer_size 2k;<br> large_client_header_buffers 6 6k;<br> request_pool_size 12k;<br>

Find more questions by tags ProxyNginxCaching