Android +cp2102?

There is a desire to use the capabilities of USB host to control a single device by serial port.

When connecting in dmesg sees the device correctly IDs him. But in /dev/ there is no hint on the com port (there is a standard UART from Tegra 4 and ttys0-3 that can not be opened under any circumstances).


Maybe someone will be able to tell, in what side to dig?

Oh yeah, the device — Transformer Prime, for reference.
October 8th 19 at 03:19
2 answers
October 8th 19 at 03:21
Just today connected a cp2102 to ubuntu — there is /dev/ttyUSB0 everything worked immediately.

In fact Android phones do not include linux kernel modules, and if not then do nothing. (unless you alter\update FS)

Have you seen this?
October 8th 19 at 03:23
thanks for the link, will read it. Yes, Linux on the desktops no problems on a Fedora here, too, everything is fine.
tried on SGS2 via USBHost. silence... in General, you need the kernel module for anyone to embed. - eveline_Gottlieb commented on October 8th 19 at 03:26

Find more questions by tags Serial portAndroidCharacter encodingUART