Availability of services simultaneously on two and more WAN with Cisco

Dear colleagues, please help in configuration of router Cisco for providing access to network services from the Internet simultaneously on two channels + NAT. Can anyone share a working solution, or give him the link, because I've tried almost everything described on cisco.com and the vast internetov.

There are marsruuter with (C181X-ADVENTERPRISEK9-M), Version 15.0(1)M3 on Board. To it come two uplinks from two different providers. One FastEthernet, the second PPPoE. Behind the router there are a pair of users and multiple servers providing a total of about 50 different services (read: ports). You need to release a subnet to the Internet (NAT) for PortForwarding on both external IP.

The problem is that when the equilibrium default routes or no AD — the router goes into balance mode and port forwarding works as I have to, but NAT is not working. If different AD — NAT works, but the services are available only on the channel with the lowest AD.

When PBR (which I don't really know how to cook) nothing works. Can certainly should revert back to 12.4 (there sure all worked), but there is no full-fledged OER.

In advance, merci.
October 8th 19 at 03:29
2 answers
October 8th 19 at 03:31
After Smoking different manuals and ways of the samurai decided the question in the following way

ip nat inside source static tcp 10.10.45.2 ISP1_IP 25 25 extendable
ip nat inside source static tcp 10.10.45.20 ISP2_IP 25 25 extendable

ip route 0.0.0.0 0.0.0.0 ISP1_IP
ip route 0.0.0.0 0.0.0.0 Dialer0 10
!
ip access-list extended NAT
10.10.45.0 0.0.0.255 permit ip any
ip access-list extended SRV1
permit ip any host 10.10.45.2
permit ip any host 10.10.45.3
ip access-list extended SRV2
permit ip any host 10.10.45.20
permit ip any host 10.10.45.30
!
route-map NAT-CLIENT-ISP2 permit 10
match ip address NAT
match interface Dialer0
!
route-map NAT permit 100
match the ip address of SRV1
set default interface FastEthernet0
!
route-map NAT permit 200
match ip address SRV2
set default interface Dialer0
!
route-map NAT-CLIENT-ISP1 permit 10
match ip address NAT
match interface FastEthernet0

It seems to work.
October 8th 19 at 03:33
I'm afraid in the case of Cisco for broadcasting on both uplinks without BGP can not do.
I got the idea.
Try trugole solution by assigning the server a second IP from the same subnet.

ip nat ins sour stat tcp 10.10.10.50 83.83.83.20 80 80 ext
ip nat ins sour stat tcp 10.10.10.51 60.60.60.20 80 80 ext

well, the corresponding rout-map

Working again and only the channel on which the smallest AD.
Honestly I don't understand this 15.0.1 - Raphaelle.White57 commented on October 8th 19 at 03:36
Bro, here version software no balalaika has. To broadcast simultaneously on two or more uplinks, it is necessary to use either a dynamic (BGP in the Internet), or proprietary crutches a La multilink. - Selena_Rath99 commented on October 8th 19 at 03:39
The version of the software is very even playing. Many features are unfinished... for example like the same OER in 12.4 — like can, but to indicate the route maps, which need "smart routing" — is impossible. By default all.
But if perverted with multiple IP some servers on one channel, the other on another channel? It should definitely work. 12.4 worked. Not here. - Raphaelle.White57 commented on October 8th 19 at 03:42
With OER is to associate no one came (don't work, route maps), and so — you can poizvraschatsya. - lizeth_Weimann commented on October 8th 19 at 03:45

Find more questions by tags Network routingNetwork administrationCisco