Why FastCGI+Nginx can't see the PHP settings?

Deployed on the server classic bunch of the Apache:8080+Nginx:80+FastCGI. In php when you access the scripts through port 80 no longer see your settings (load default). I tried to set the settings via php_value in .htaccess — still they focus not see.
And through 8080 port all settings are normally tightened.
Compare: http://clio.su/test.php vs. http://clio.su:8080/test.php (the parameter upload_max_filesize to test in php.ini 4M exhibited, in .htaccess 8M, default 2M)

What you need to correct in nginx.conf (httpd.conf) to php.ini also participated in the work of the ligaments using fastcgi? I feel that it solves the problem elegantly, but shoveled Yandex, I haven't found a solution.

PS: And still a passing question, too, is associated with the fastcgi. When using the php mail() function all mail is now sent with the field FROM: ... and therefore zarulivaet postal service because of invalid addresses. Php variable sendmail_from is not applied.

UPD: a Little clarification. We spawn_fcgi
October 14th 19 at 11:56
4 answers
October 14th 19 at 11:58
a classic bunch of the Apache:8080+Nginx:80+FastCGI
WTF? You'll have to determine — or Apache, or fastcgi. A classic bunch of this
nginx:80 --> apache:8080, or:
nginx:80 --> fastcgi(php-fpm):8080
Still wystapieniu rights, and you my friend monster frankensein like trying to revive. - harold_Nicolas commented on October 14th 19 at 12:01
A small clarification. We spawn_fcgi - elda_Wisoky31 commented on October 14th 19 at 12:04
as above already written you city anything, first decide what mode you need to run PHP: the Apache module or through fastCGI.
If module, then you don't need fastCGI at all, nastraivanie nginx for proxying requests to Apache which is most likely already configured the PHP module(in most distributions by default), at present most of the articles just about this option.
If a demon for fastgci the question arises why do you need Apache? configure the nginx+fastcgi+php-fpm on this version of the articles not less.

If you to sort of task is certainly necessary and Apache and nginx, and PHP but would steadily and rapidly worked — choose the first option module. - gina_Harv commented on October 14th 19 at 12:07
October 14th 19 at 12:00
Have Fastcgi process rights in listing /usr/local/etc/ or reading /usr/local/etc/php.ini?
October 14th 19 at 12:02
about a passing question: how do you want to work? What settings cause the mail () function? Which mail server?
October 14th 19 at 12:04
You have clio.su/test.php at the beginning of the Loaded Configuration File (none). In your case, judging by the fact that the option Configuration File (php.ini) Path /usr/local/etc then the fastcgi process does not have permission to read the file /usr/local/etc/php.ini

It is worth to consider, depending on the OS. In Ubuntu for example, the individual configs of PHP to run under Apache, Cli and CGI. i.e. in the directory /etc/php5/ cli has subfolders/ apache/ cgi/ in every your php.ini and downloaded respectively, from the folders how run php
Where are all the Apache did not understand.

Find more questions by tags NginxHostingFastCGIPHP