How to fix the download of CentOS (UEFI+GPT)?

Comrades, I need your help. I am new to Linux and have encountered the following problem:
is the laptop (lenovo y510p bios updated to the latest version) with UEFI, and have two hard drives (both formatted gpt) to it which are: HDD1 and HDD2 with Windows10 with CentOS7. First, the laptop worked the drive with Windows, then worked there HDD2 with cantou. If then again work on Windows and try to run CentOS, it turns out this error:
Failed to open \EFI\BOOT\grubx64.efi - Not Found
Failed to load image \EFI\BOOT\grubx64.efi: Not Found
start_image() returned Not Found

All this is treated by manual with peek-a-Boo LINK

The manual:

1. To go to BIOS and set the Boot Mode to UEFI value.
2. To start with a bootable USB drive and open a terminal.
3. In terminal to get root rights.
4. Run the following commands:
su root
mount /dev/centos/root /mnt
mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
modprobe efivars
chroot/mnt
efibootmgr --create --label CentOS --disk /dev/sda1 --loader "\EFI\centos\shim.efi"


Please help me to fix it and, if possible, to deal with the causes. For UEFI a bunch of articles on Habre I read (for example), but do not understand what is the problem in this case. Windows something in NVRAM writes every time you load your record? Thanks in advance.
March 12th 20 at 08:02
0 answer

Find more questions by tags CentOS