Why not access from this computer to phpmyadmin?

Please tell me, after installing phpmyadmin on centos when trying to log in from another computer via the browser get the message.
Forbidden
You don't have permission to access /phpmyadmin/ on this server.
Version of httpd
Server version: Apache/2.4.6 (CentOS)
Server built: Jul 27 2018 13:48:59
The error log in httpd
[Wed Oct 10 10:55:20.127987 2018] [mpm_prefork:notice] [pid 2419] AH00170: caught SIGWINCH, shutting down gracefully
[Wed Oct 10 10:55:21.208769 2018] [suexec:notice] [pid 2451] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using localhost.localdomain. Set the 'ServerName' directive globally to suppress this message
[Wed Oct 10 10:55:21.230472 2018] [auth_digest:notice] [pid 2451] AH01757: generating secret for digest authentication ...
[Wed Oct 10 10:55:21.231036 2018] [lbmethod_heartbeat:notice] [pid 2451] AH02282: No slotmem from mod_heartmonitor
[Wed Oct 10 10:55:21.233679 2018] [mpm_prefork:notice] [pid 2451] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2 k-fips configured -- resuming normal operations
[Wed Oct 10 10:55:21.233726 2018] [core:notice] [pid 2451] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

config phpmyadmin in httpd

# phpMyAdmin - Web based MySQL browser written in php
#
# Allows only localhost by default
#
# But allowing phpMyAdmin to anyone other than localhost should be considered
# dangerous unless properly secured by SSL

Alias /phpMyAdmin /usr/share/phpMyAdmin
Alias /phpmyadmin /usr/share/phpMyAdmin

AddDefaultCharset UTF-8


# Apache 2.4

#Require ip 127.0.0.1
#Require ip ::1
Require all granted

# Apache 2.2
Order Deny,Allow
Deny from All
Allow from 127.0.0.1
Allow from ::1

# Apache 2.4

#Require ip 127.0.0.1
#Require ip ::1
Require all granted

# Apache 2.2
Order Deny,Allow
Deny from All
# Allow from All
# Allow from ::1
Require all granted


# These directories do not require access over HTTP - taken from the original
# phpMyAdmin upstream tarball
#

Order Deny,Allow
Deny from All
Allow from None

Order Deny,Allow
Deny from All
Allow from None

Order Deny,Allow
Deny from All
Allow from None

# This configuration prevents mod_security at phpMyAdmin directories from
# filtering SQL etc. This may break your mod_security implementation.
#
#
#
# SecRuleInheritance Off
#
#
Help please, I highly recommend it.
March 12th 20 at 08:05
3 answers
March 12th 20 at 08:07
to mysql access to the database is by default only accessible with localhost
you need to config mysql to specify Ip addresses that the database can access
With log on locally I get the same garbage
5bbdb7b5ae0a6508131824.png - Elias.Kreiger commented on March 12th 20 at 08:10
Mysql config does not contain anything like that

# For advice on how to change settings please see
# dev.mysql.com/doc/refman/8.0/en/server-configurati...

[mysqld]
#
# Remove leading # and set to the amount of RAM for the most important data
# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.
# innodb_buffer_pool_size = 128M
#
# Remove the leading "# " to disable binary logging
# Binary logging captures changes between backups and is enabled by
# default. It's default setting is log_bin=binlog
# disable_log_bin
#
# Remove leading # to set options mainly useful for reporting servers.
# The server defaults are faster for transactions and fast SELECTs.
# Adjust sizes as needed, experiment to find the optimal values.
# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M
#
# Remove leading # to revert to previous value for default_authentication_plugin,
# this will increase compatibility with older clients. For background, see:
# https://dev.mysql.com/doc/refman/8.0/en/server-sys...
# default-authentication-plugin=mysql_native_password

datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid - Elias.Kreiger commented on March 12th 20 at 08:13
@Elias.Kreiger, damn it, and it does not bother you?
Order Deny,Allow
Deny from All
Allow from None

Order Deny,Allow
Deny from All
Allow from None

Order Deny,Allow
Deny from All - Boris_Gaylord commented on March 12th 20 at 08:16
@Elias.Kreiger, you yourself from all closed - Boris_Gaylord commented on March 12th 20 at 08:19
@Boris_Gaylord, got it, thanks, I will try. - Elias.Kreiger commented on March 12th 20 at 08:22
March 12th 20 at 08:09
You have to config Apache is written:

#Apache X. X

#Require ip 127.0.0.1
#Require ip ::1
Require all granted

# Apache 2.2
Order Deny,Allow
Deny from All # - deny access from all ip
Allow from 127.0.0.1 # allow from 127.0.0.1 (this localhost)
Allow from ::1 # allow from ::1 (this is also localhost)


You need to write:
Order Deny,Allow
Allow from All # access to phpmyadmin from any ip address
March 12th 20 at 08:11
Gave phpmyadmin.conf to this mind, like everything is allowed that is possible, but the problem remained.
I do not know where to dig... what a delusion.
# phpMyAdmin - Web based MySQL browser written in php
#
# Allows only localhost by default
#
# But allowing phpMyAdmin to anyone other than localhost should be considered
# dangerous unless properly secured by SSL

Alias /phpMyAdmin /usr/share/phpMyAdmin
Alias /phpmyadmin /usr/share/phpMyAdmin

AddDefaultCharset UTF-8


# Apache 2.4

Require all granted
Require ip ::1

# Apache 2.2
Order Deny,Allow
Deny from None
Allow from All
Allow from 192.168.0.82
Allow from ::1

# Apache 2.4

Require all granted
#Require ip ::1

# Apache 2.2
Order Deny,Allow
Deny from None
Allow from All
Allow from 192.168.0.82
Allow from ::1


# These directories do not require access over HTTP - taken from the original
# phpMyAdmin upstream tarball
#

Order Deny,Allow
Allow from All
Deny from None
#Allow from None

Order Deny,Allow
Allow from All
Deny from None
#Allow from None

Order Deny,Allow
Allow from All
Deny from None
#Allow from None

# This configuration prevents mod_security at phpMyAdmin directories from
# filtering SQL etc. This may break your mod_security implementation.
#
#
#
# SecRuleInheritance Off
#
#
AllowOverride All
find this Directive in the config of Apache and allow. Everywhere to start. - Kira3 commented on March 12th 20 at 08:14
Hi, the config to this sight
Alias /phpMyAdmin /usr/share/phpMyAdmin
Alias /phpmyadmin /usr/share/phpMyAdmin

AddDefaultCharset UTF-8
Require all granted

Require all granted


Order Deny,Allow
Deny from All
Allow from None

Order Deny,Allow
Deny from All
Allow from None

Order Deny,Allow
Deny from All
Allow from None

The problem remains, can still where is the config from phpmyadmin - Elias.Kreiger commented on March 12th 20 at 08:17

Find more questions by tags CentOSphpMyAdminRed Hat Enterprise Linux