How to solve the following error when running uwsgi?

Trying zapustas server for Django. I use nginx and uwsgi. Vps hosting with Ubuntu 18.04 LTS.

When run, writes the following:
root@ovz1:~# uwsgi --ini /data/isaus/conf/mysite_uwsgi.ini
[uWSGI] getting INI configuration from /data/isaus/conf/mysite_uwsgi.ini
*** Starting uWSGI 2.0.17.1 (64bit) on [Wed Oct 10 13:20:07 2018] ***
compiled with version: 7.3.0 on 09 October 2018 13:04:25
os: Linux 4.15.0 #1 SMP Mon Jun 27 18:26:02 MSK 2018
nodename: ovz1.cjgo.1qyn6.vps.myjino.ru
machine: x86_64
clock source: unix
detected number of CPU cores: 2
current working directory: /root
detected binary path: /usr/local/bin/uwsgi
!!! no internal routing support, rebuild with pcre support !!!
uWSGI running as root, you can use --uid/--gid/--chroot options
*** WARNING: you are running uWSGI as root !!! (use the --uid flag) ***
chdir() to /data/isaus/project
your processes number limit is 385934
your memory page size is 4096 bytes
detected max file descriptor number: 1024
lock engine: pthread robust mutexes
thunder lock: disabled (you can enable it with --thunder-lock)
uwsgi socket 0 bound to UNIX address /data/isaus/isaus.sock fd 3
uWSGI running as root, you can use --uid/--gid/--chroot options
*** WARNING: you are running uWSGI as root !!! (use the --uid flag) ***
Python version: 3.6.6 (default, Sep 12 2018, 18:26:19) [GCC 8.0.1 20180414 (experimental) [trunk revision 259383]]
*** Python threads support is disabled. You can enable it with --enable-threads ***
Python main interpreter initialized at 0x56505faddc50
uWSGI running as root, you can use --uid/--gid/--chroot options
*** WARNING: you are running uWSGI as root !!! (use the --uid flag) ***
your server socket listen backlog is limited to 100 connections
your mercy for graceful operations on workers is 60 seconds
mapped 801944 bytes (783 KB) for 10 cores
*** Operational MODE: preforking ***
WSGI app 0 (mountpoint=") ready in 0 seconds on interpreter 0x56505faddc50 pid: 2799 (default app)
uWSGI running as root, you can use --uid/--gid/--chroot options
*** WARNING: you are running uWSGI as root !!! (use the --uid flag) ***
*** uWSGI is running in multiple interpreter mode ***
spawned uWSGI master process (pid: 2799)
spawned uWSGI worker 1 (pid: 2801, cores: 1)
spawned uWSGI worker 2 (pid: 2802, cores: 1)
spawned uWSGI worker 3 (pid: 2803, cores: 1)
spawned uWSGI worker 4 (pid: 2804, cores: 1)
spawned uWSGI worker 5 (pid: 2805, cores: 1)
spawned uWSGI worker 6 (pid: 2806, cores: 1)
spawned uWSGI worker 7 (pid: 2807, cores: 1)
spawned uWSGI worker 8 (pid: 2808, cores: 1)
spawned uWSGI worker 9 (pid: 2809, cores: 1)
spawned uWSGI worker 10 (pid: 2810, cores: 1)


Searching the Internet found that the problem is in the line:
!!! no internal routing support, rebuild with pcre support !!!


Tried to do as advised:
pip3 uninstall uwsgi
apt-get remove uwsgi
apt-get install libpcre3 libpcre3-dev
pip3 install uwsgi


It did not help.
Maybe something is not correctly configured.
nginx seems to work
March 12th 20 at 08:08
0 answer

Find more questions by tags uWSGIUbuntuNginxDjango