How to fix the error in the file seo_url.php the website on Opencart?

I use Opencart Version 2.3.0.2, set up a website on a local server (Open Server) the site works fine, while migrating to hosting gives errors, please tell me how can I fix it?

Saw a similar theme, writing that the case in the settings file .htaccess and the hosting support helped to solve the issue, God knows how. But my hosting support replied that they did not.

I tried to put another website, without Seo Url, everything works.

Produces here such error the design loads:

Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: scheme in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122Notice: Undefined index: host in /home/komy/stroyka.icu/www/catalog/controller/startup/seo_url.php on line 122

5bbe8c2d71c9f689423547.png

The contents of the file .htaccess :

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: www.opencart.com

# Options +SymLinksIfOwnerMatch

# Prevent Directoy listing
Options-Indexes

# Prevent Direct Access to files

Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
March 12th 20 at 08:11
0 answer

Find more questions by tags OpenCart