How to get rid of errors `jitter buffer full` ffmpeg?

How to get rid of errors `jitter buffer full`?
I use ffmpeg from one of the last shots.
ffmpeg version N-90078-gf611fef Copyright (c) 2000-2018 the FFmpeg developers


The problem is that from the camera over rtsp there is such a thread:
ibb.co/fmckCc
From the camera it can't be fixed, because!

I take it like this:

ffmpeg \
-strict experimental \
-fflags + genpts \
-fflags + latm \
-seek2any 1 \
-avoid_negative_ts + make_zero \
-max_delay 5000000 \
-rtsp_transport udp \
-i rtsp: // admin: @ 192.168.87.21: 554/0? .sdp \
-map 0 \
-r 15 \
-c: v copy \
-an \
-f mpegts udp: //239.0.0.1: 1234? ttl = 1? pkt_size = 1316


In the output you see here are the errors:
[rtsp @ 0x154d180] jitter buffer full
[rtsp @ 0x154d180] RTP: missed 1 packets
[rtsp @ 0x154d180] jitter buffer full
[rtsp @ 0x154d180] RTP: missed 1 packets
[rtsp @ 0x154d180] jitter buffer full
[rtsp @ 0x154d180] RTP: missed 2 packets
[rtsp @ 0x154d180] jitter buffer full
[rtsp @ 0x154d180] RTP: missed 4 packets

because of this, the picture falls apart.

I increased the udp buffer in the settings of the Linux kernel:

net.core.rmem_max = 16777216
net.core.wmem_max = 16777216
net.ipv4.udp_mem = 8388608 12582912 16777216
net.ipv4.tcp_rmem = 4096 87380 8388608
net.ipv4.tcp_wmem = 4096 65536 8388608

But it did not solve my problem.

How to take the correct RTP ?
June 7th 19 at 15:40
0 answer

Find more questions by tags Video broadcastFFmpeg