Ruby/How to solve a problem with a server error?

To see why this extension failed to compile, please check the mkmf.log which can
be found here:

C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sqlite3-1.4.0 for
inspection.
Results logged to
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.0/gem_make.out

An error occurred while installing sqlite3 (1.4.0), and Bundler cannot continue.
Make sure that `gem install sqlite3 -v '1.4.0' --source 'https://rubygems.org/"
succeeds before bundling.

In Gemfile:
sqlite3

then this error
Could not find gem 'turbolinks (~> 5) x86-mingw32' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.
March 19th 20 at 08:24
2 answers
March 19th 20 at 08:26
Check the version of sqlite3. Try to install the version 1.3.6, I helped with a similar case.
To do this, specify the version explicitly:
gem 'sqlite3', '~> 1.3.6'
helped writes

To see why this extension failed to compile, please check the mkmf.log which can be found here:

C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sqlite3-1.4.0 for inspection.
Results logged to C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.0/gem_make.out
Gems updated: did_you_mean nokogiri rdoc sqlite3 - Sheila_Stokes4 commented on March 19th 20 at 08:29
What's in the log pisey? - Clement15 commented on March 19th 20 at 08:32
I have the same error was made as you wrote "put gem 'sqlite3', '~> 1.3.6'" and all server working. Thank you - wava_Kiehn commented on March 19th 20 at 08:35
March 19th 20 at 08:28
Rails generally stays close to the latest released Ruby version when it's released:

5 requires Ruby Rails 2.2.2 or newer.
Rails 4 prefers Ruby 2.0 and requires 1.9.3 or newer.
Rails 3.2.x is the last branch to support Ruby 1.8.7.
Rails 3 and above require Ruby 1.8.7 or higher. Support for all of the previous Ruby versions has been dropped officially. You should upgrade as early as possible.
Though, exceptions are also there:
A list of tested versions of ruby on rails thread:

Rails 3.0

1.8.7
1.9.2
1.9.3
Rails 3.1

1.8.7
1.9.2
1.9.3
Rails 3.2

1.8.7
1.9.2
1.9.3
2.0.0
2.1.8
2.2.6
2.3.3
Rails 4.0

1.9.3
2.0.0
2,1
2,2
Rails 4.1

1.9.3
2.0.0
2,1
2.2.4
2.3.0
Rails 4.2

1.9.3
2.0.0-p648
2.1.10
2.2.10
2.3.8
2.4.5
Rails 5.0

2.2.10
2.3.8
2.4.5
Rails 5.1

2.2.10
2.3.7
2.4.4
2.5.1
Rails 5.2

2.2.10
2.3.7
2.4.4
2.5.1
- tyrel.Waelchi commented on March 19th 20 at 08:31

Find more questions by tags Ruby gemsSQLiteRuby on Rails