Widget on wordpress put but does not appear to be input?

Anyway added your widget, it is displayed but there is no InputB, but there are no errors...I do not understand what is wrong?
Or rather there are input but with the class hidden and indeed it is not what I wanted.
<?php 

add_action('widgets_init', 'f_collection');

f_collection function() {
register_widget('F_collection');
}

class F_collection extends WP_Widget{

 F_collection function() {
 $widget_ops = array(
 'classname' => 'myTempl',
 'description' => 'Description'
);

 $control_ops = array(
 'width' => 300,
 'height' => 350
);

 $this->WP_Widget('fcollection', 'Featured Collection', $widget_ops, $control_ops);
}
}

function update($new_instance, $old_instance){

 $instance = $old_instance;

 $instance['title'] = strip_tags($new_instance['title']);
 $instance['pcount'] = strip_tags($new_instance['pcount']);

 return $instance;
}

function form($instance) {

 $defaults = array(
 'title' => 'Featured Collection',
 'pcount' => 9
);

 $instance = wp_parse_args((array)$instance, $defaults); ?>
<p>
 <label for="<?php echo $this->get_field_id('title')?>">Title</label>
 <input id="<?php echo $this->get_field_id('title')?>" name="<?php echo $this->get_field_name('title')?>" value="<?php echo $instance['title'];?>" style="width:100%;">

</p>
<p>
 <label for="<?php echo $this->get_field_id('pcount')?>">Products Count</label>
 <input id="<?php echo $this->get_field_id('pcount')?>" name="<?php echo $this->get_field_name('pcount')?>" value="<?php echo $instance['pcount'];?>" style="width:100%;">

</p>

<?php
}


?>
March 19th 20 at 08:26
0 answer

Find more questions by tags WordPress