What to do if npm install throws a lot of errors?

Very newcomer, trying to repeat, as here: https://youtu.be/sRO3dxLa4S0?list=PLyf8LgkO_8q-Izp... (time reference was deliberate), but something does not work. How can it be fixed?

Here's the thing:
C:\Users\nick4\Desktop\ready_html>npm install
npm WARN deprecated gulp-minify-css@1.2.4: Please use gulp-clean-css
npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
npm WARN deprecated win-spawn@2.0.0: use [cross-spawn](https://github.com/IndigoUnited/node-cross-spawn) or [cross-spawn-async](https://github.com/IndigoUnited/node-cross-spawn-async) instead.
npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs is 4 for compatibility with current and future versions of Node.js
npm WARN deprecated browserslist@0.4.0: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs is 4 for compatibility with current and future versions of Node.js

> node-sass@3.13.1 install C:\Users\nick4\Desktop\ready_html\node_modules\node-sass
> node scripts/install.js

Downloading binary from https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-67_binding.node
Cannot download "https://github.com/sass/node-sass/releases/download/v3.13.1/win32-x64-67_binding.node":

HTTP error 404 Not Found

Hint: If github.com is not accessible in your location
 try setting a proxy via the HTTP_PROXY, e.g.

 export HTTP_PROXY=http://example.com:1234

or configure proxy via npm

 npm config set proxy http://example.com:8080

> gulp-express@0.3.5 install C:\Users\nick4\Desktop\ready_html\node_modules\gulp-express
> echo "*** Please use [gulp-live-server] instead! *** "

"*** Please use [gulp-live-server] instead! *** "

> node-sass@3.13.1 postinstall C:\Users\nick4\Desktop\ready_html\node_modules\node-sass
> node scripts/build.js

Building: C:\Program Files\nodejs\node.exe C:\Users\nick4\Desktop\ready_html\node_modules\node-gyp\bin\node-gyp.js rebuild --verbose --libsass_ext= libsass_cflags --= --libsass_ldflags= --libsass_library=
gyp info it worked if it ends with ok
gyp verb cli [ 'C:\\Program Files\\nodejs\\node.exe',
gyp verb cli 'C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\node-gyp\\bin\\node-gyp.js',
gyp verb cli 'rebuild',
gyp verb cli '--verbose',
gyp verb cli '--libsass_ext=',
gyp verb cli '--libsass_cflags=',
gyp verb cli '--libsass_ldflags=',
gyp verb cli '--libsass_library=' ]
gyp info using node-gyp@3.8.0
gyp info using node@11.12.0 | win32 | x64
gyp verb command rebuild []
gyp verb command clean []
gyp verb clean removing "build" directory
gyp verb command configure []
gyp verb check python checking for Python executable "python2" in the PATH
gyp verb `which` failed Error: not found: python2
gyp verb `which` failed at getNotFoundError (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:13:12)
gyp verb `which` failed at F (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:68:19)gyp verb `which` failed at E (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:80:29)gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:89:16
gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\isexe\index.js:42:5
gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\isexe\windows.js:36:5
gyp verb `which` failed at FSReqCallback.oncomplete (fs.js:158:21)
gyp verb `which` failed python2 { Error: not found: python2
gyp verb `which` failed at getNotFoundError (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:13:12)
gyp verb `which` failed at F (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:68:19)gyp verb `which` failed at E (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:80:29)gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:89:16
gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\isexe\index.js:42:5
gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\isexe\windows.js:36:5
gyp verb `which` failed at FSReqCallback.oncomplete (fs.js:158:21)
gyp verb `which` failed stack:
gyp verb `which` failed 'Error: not found: python2\n at getNotFoundError (C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\which\\which.js:13:12)\n at F (C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\which\\which.js:68:19)\n at E (C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\which\\which.js:80:29)\n at C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\which\\which.js:89:16\n at C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\isexe\\index.js:42:5\n at C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\isexe\\windows.js:36:5\n at FSReqCallback.oncomplete (fs.js:158:21)',
gyp verb `which` failed, code: 'ENOENT' }
gyp verb check python checking for Python executable "python" in the PATH
gyp verb `which` failed Error: not found: python
gyp verb `which` failed at getNotFoundError (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:13:12)
gyp verb `which` failed at F (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:68:19)gyp verb `which` failed at E (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:80:29)gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:89:16
gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\isexe\index.js:42:5
gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\isexe\windows.js:36:5
gyp verb `which` failed at FSReqCallback.oncomplete (fs.js:158:21)
gyp verb `which` failed python { Error: not found: python
gyp verb `which` failed at getNotFoundError (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:13:12)
gyp verb `which` failed at F (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:68:19)gyp verb `which` failed at E (C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:80:29)gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\which\which.js:89:16
gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\isexe\index.js:42:5
gyp verb `which` failed at C:\Users\nick4\Desktop\ready_html\node_modules\isexe\windows.js:36:5
gyp verb `which` failed at FSReqCallback.oncomplete (fs.js:158:21)
gyp verb `which` failed stack:
gyp verb `which` failed 'Error: not found: python\n at getNotFoundError (C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\which\\which.js:13:12)\n at F (C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\which\\which.js:68:19)\n at E (C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\which\\which.js:80:29)\n at C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\which\\which.js:89:16\n at C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\isexe\\index.js:42:5\n at C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\isexe\\windows.js:36:5\n at FSReqCallback.oncomplete (fs.js:158:21)',
gyp verb `which` failed, code: 'ENOENT' }
gyp verb could not find "python". checking python launcher
gyp verb could not find "python". guessing location
gyp verb ensuring that file exists: C:\Python27\python.exe
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.
gyp ERR! stack at PythonFinder.failNoPython (C:\Users\nick4\Desktop\ready_html\node_modules\node-gyp\lib\configure.js:484:19)
gyp ERR! stack at PythonFinder.<anonymous> (C:\Users\nick4\Desktop\ready_html\node_modules\node-gyp\lib\configure.js:509:16)
gyp ERR! stack at C:\Users\nick4\Desktop\ready_html\node_modules\node-gyp\node_modules\graceful-fs\polyfills.js:282:31
gyp ERR! stack at FSReqCallback.oncomplete (fs.js:158:21)
gyp ERR! System Windows_NT 10.0.17763
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\nick4\\Desktop\\ready_html\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
gyp ERR! cwd C:\Users\nick4\Desktop\ready_html\node_modules\node-sass
gyp ERR! node-v v11.12.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
Build failed with error code: 1
npm WARN gulp-project@1.0.0 No repository field.
npm WARN gulp-project@1.0.0 No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! node-sass@3.13.1 postinstall: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-sass@3.13.1 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\nick4\AppData\Roaming\npm-cache\_logs\2019-03-25T11_20_16_141Z-debug.log
March 19th 20 at 08:28
2 answers
March 19th 20 at 08:30
I hope the eye won't break. Don't know how it is more aesthetically pleasing insert to catabile was.
March 19th 20 at 08:32
Try using a modern version of package node-sass. The installation of this npm package, deflate binary from github repository, but for some reason the developers cleaned up some of the releases or changed the format of the tags, thus breaking the ability to install old versions of the package.
Tag v3.13.1 I in the repository https://github.com/sass/node-sass/tags in focus not see.

P. S. to Follow tutorial 2015 - well is during this time quite a lot has changed, but gulp, no one uses in favor of webpack.
Thank you. No idea what I did but it somehow worked) - Judah commented on March 19th 20 at 08:35

Find more questions by tags npm