Transmission daemon Error: permission denied how to fix?

When you start downloading a new torrent immediately displays this error:
Transmission daemon Error: permission denied
I guess the problem with access rights, how to fix
System Ubuntu Linux 18.04.2

Configs:
settings.json

{
"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "0.0.0.0",
"bind-address-ipv6": "::",
"blocklist-enabled": false,
"blocklist-url": "www.example.com/blocklist",
"cache-size-mb": 4,
"dht-enabled": true,
"download-dir": "/media/FILMS",
"download-limit": 100,
"download-limit-enabled": 0,
"download-queue-enabled": true,
"download-queue-size": 5,
"encryption": 1,
"idle-seeding-limit": 30,
"idle-seeding-limit-enabled": false,
"incomplete-dir": "/media/.incomplete",
"incomplete-dir-enabled": true,
"lpd-enabled": false,
"max-peers-global": 200,
"message-level": 1,
"peer-congestion-algorithm": "",
"peer-id-ttl-hours": 6,
"peer-limit-global": 200,
"peer-limit-per-torrent": 50,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": "default",
"pex-enabled": true,
"port-forwarding-enabled": false,
"preallocation": 1,
"prefetch-enabled": true,
"queue-stalled-enabled": true,
"queue-stalled-minutes": 30,
"ratio-limit": 2,
"ratio-limit-enabled": false,
"rename-partial-files": true,
"rpc-authentication-required": false,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-host-whitelist": "",
"rpc-host-whitelist-enabled": true,
"rpc-password": "{8f756f1341a8a27ad60d25ed4f95ced0e1ea7fe3tuatbbjy",
"rpc-port": 9091,

smb.conf
[global]
security = user
directory mode = 777
map to guest = Bad User
workgroup = WORKGROUP
server string = Samba
create mode = 777
force directory mode = 777
writeable = yes
force create mode = 777
os level = 20

[TORRENTS]
path = /media/TORRENTS
browseable = Yes
guest ok = Yes
writeable = Yes
public = yes

[.incomplete]
path = /media/.incomplete
browseable = Yes
guest ok = Yes
writeable = Yes
public = yes
March 19th 20 at 08:32
2 answers
March 19th 20 at 08:34
>"rpc-host-whitelist-enabled": true,

Make false.
Did not help - Darrick.Brakus commented on March 19th 20 at 08:37
March 19th 20 at 08:36
Good evening.
Strange law You have a "42777"
sudo chown user:user /media/FILMS
or recursively, like so
sudo chown-R user:user /media/FILMS
Instead of user put your login in the system.
Still did not help, changed right on cue, then moved on to the web interface of the torrent added the torrent, then the torrent stopped working,restarted the service of the torrent, he began to download somewhere 5 megabytes downloaded and gave the same error about the rights - Darrick.Brakus commented on March 19th 20 at 08:39
In the end, helped in the preferences settings.json when the parameter set incomplete-dir-enabled: false instead of true - Darrick.Brakus commented on March 19th 20 at 08:42

Find more questions by tags BitTorrentUbuntuLinux