How to disable hide the node_modules in phpstorm?

What I did:
1. removed/disabled all plugins
2. removed folder .idea
3. ran invalidate and restart many times
4. checked scopes, show excluded files
5. updated phpstorm
6. read a bunch of advice about vue-for-idea

5c99f34c11661936220184.jpeg5c99f3551ccb6777638924.jpeg
March 19th 20 at 08:38
1 answer
March 19th 20 at 08:40
Solution
We in PhpStorm with a colleague from WebStorm thought and no entries were decided, comes to mind only Show Excluded Files.
For fun, you can try to start with a clean configuration file (rename the %USERPROFILE%\.PhpStorm2018.3 and start the Storm without importing settings), open the project and see how it will be.
If it is good, then it somehow in the config.
If it is bad, you can try some newly created c project node_modules.
If still bad, then we will think again.
rename %USERPROFILE%\.PhpStorm2018.3 and start the Storm without importing settings

it helped. I have two folders PhpStorm2018.3, PhpStorm2018.2
and each weighs 16GB - is this normal? Now you can delete them, I guess - Morris.Mueller commented on March 19th 20 at 08:43
The system folder can be banging quietly, there are caches and any statistics, and it is likely that this folder takes up a lot.
To demolish config is possible if you just do not need this config to be restored, like if for instance some of custom settings you are missing. But it doesn't have a lot to weigh, so you can leave. - forest commented on March 19th 20 at 08:46

Find more questions by tags PhpStorm