Why OpenVPN clients there is no sound in incoming calls FreePBX?

The bottom line is this: delendik connects via OpenVPN to the office OpenVPN server, passing through the Mikrotik router. Out routes the employee gets from the OpenVPN subnet 10.8.0.0/24 to subnet office 192.168.24.0/23 and gets access to all its resources, including for telephony FreePBX. From the PBX and phone communication to all remote workers are. Udalenie calls from phones within the subnet of the office are working properly, but if you call from the office udalenku, can not hear anything.

In what direction to look and what to do?
March 19th 20 at 08:39
3 answers
March 19th 20 at 08:41
Solution
The decision - elikem in FreePBX, web-face Settings>Asterisk SIP Settings. In the NAT menu, specify the subnet of the OpenVPN client and all starts to work.
March 19th 20 at 08:43
NAT - 90%.
Routing to udalenie - 10%.
March 19th 20 at 08:45
In asterisk should be added to the network of udalenie in localnet
plus uralensis must register with the internal address of the asterisk
and on the client udalenie must be turned off stun server in the settings of the Softphone

Find more questions by tags FreePBXNetwork routingOpenVPNAsterisk