Webpack-dev-server or infinite loading localhost?

Set up development environment under react, with the introduction of the npm command start just go straight to localhost:8080 and stupidly goes infinite loading page (not the browser), until it stops responding (and will not give the "aw, snap"). At first I thought the problem in the port (change to another), did not help, then I think the problem is in the hosts file but everything is OK... it is noteworthy that the console in the browser, no error is issued and the build occurs without error. Operating system macos, it worked on Windows and nothing like this has happened. Logic in files no respectively no timers or loops that are able stopnot work page no.

const htmlWebpackPlugin = require("html-webpack-plugin");
const path = require("path");

module.exports = {
devtool: "source-map",
entry: "./frontend/src/index.js",
output: {
path: path.resolve(__dirname + "/dist/"),
filename: "bundle.js"
module: {
rules: [
test: /\.(js|jsx)$/,
exclude: /node_modules/,
use: {
loader: "babel-loader"
test: /\.(css|scss)$/,
use: [
plugins: [
new htmlWebpackPlugin({
template: "./frontend/public/index.html",
filename: "./index.html"


"name": "random_app",
"version": "1.0.0",
"description": "",
"main": "index.js",
"scripts": {
"start": "webpack-dev-server --development-mode --hot --open",
"build": "webpack --mode production"
"author": "",
"license": "ISC",
"devDependencies": {
"@babel/core": "^7.1.2",
"@babel/preset-env": "^7.1.0",
"@babel/preset-react": "^7.0.0",
"autoprefixer": "^9.3.0",
"babel-loader": "^8.0.4",
"css-loader": "^1.0.0",
"html-webpack-plugin": "^3.2.0",
"node-sass": "^4.9.4",
"postcss-loader": "^3.0.0",
"sass-loader": "^7.1.0",
"style-loader": "^0.23.1",
"webpack": "^4.22.0",
"webpack-cli": "^3.1.2",
"webpack-dev-server": "^3.2.1"
"dependencies": {
"react": "^16.5.2",
"react-dom": "^16.5.2",
"react-router-dom": "^5.0.0"
March 19th 20 at 08:42
1 answer
March 19th 20 at 08:44
well not specifically say but there is paro assumptions publicPath: '/' in the output and add hot seems best to specify in
settings dev server devSerever{ hot:true, port: 9000} .

Find more questions by tags WebpackReactLocal server