Why the external component is set to 1C, but does not create the object?

On the instructions manual integrated sition in the database based on the famous CH-Com1S. Windows Server 2012 (64). On a thin client (32) in the RDP works fine, but there was a mission to move to the user's computer(Windows XP 32). To do this, set up IIS and published the database. Picked up not from the browser as the thin client. Base runs and everything works except Softphone. Here is the piece of code:
attempt
Ostrovitianova(Adescamenti);
exception
to inform(of Opisaniyami());
 report("failed to set the external component");
Return;
Connectorid;

attempt
 Podklucichnykh(Adescamenti, "Mypcname");
 Vneshneekonomicheskogo = 1;
exception
to inform(of Opisaniyami());
 Report("failed to connect an external component");
Return;
Connectorid;

attempt
 Телефон_1С = New("AddIn.Mypcname.ServTel");
exception
to inform(of Opisaniyami());
 Report("failed to connect to phone");
Return;
 Connectorid;

error:

{Processing.CallCenter.Form.Form.Form(125)}: Type is not defined (AddIn.Mypcname.ServTel)
Failed to connect phone!!!


ie component is installed and connected, but eject is not created. This problem is only on the user's computer. If you connect via RDP to the server and database specify the address as localhost, then it works.

Why? How to ispraviti? Where to dig? I think it is somewhere in the IIS settings but don't know where.
March 19th 20 at 08:51
1 answer
March 19th 20 at 08:53
I think that thin client run under a user that has no rights to install components. There IIS not exactly where.

Find more questions by tags 1C