Why can't connect autoload.php?

I get the error:
Fatal error: require_once(): Failed opening required 'http://dist.(must admit).loc/vendor/autoload.php' (include_path='.;c:/ospanel/modules/php/PHP-7.2-x64;c:/ospanel/modules/php/PHP-7.2-x64/PEAR/pear') in C:\OSPanel\domains\dist.(must admit).loc\public\index.php on line 3


Connection code:
require_once __DIR__ . '/vendor/autoload.php';
$route = new \Klein\Klein();


Here is the project structure:
5c9c6e69e4408877214983.png

First time doing such a project...)) Help pliz
March 19th 20 at 08:57
1 answer
March 19th 20 at 08:59
Solution
in C:\OSPanel\domains\dist.(must admit).loc\public\index.php


require_once __DIR__ . '/vendor/autoload.php';

Do not mind that in the public there is no vendor directory?) It would be correct like this:

require_once __DIR__ . '/../vendor/autoload.php';

Find more questions by tags ComposerPHP