Mixed Content mixed connection of contact form 7, how to fix?

Hi all. The point is that WP usually was create a bunch of duplicate pages it is unnecessary for the type of site/2018 website/123 website/write/2 so I decided to fight it. Because Yandex began to swear that they no titlos, description, etc. the response from the server 200. In General they have a negative effect. The solution I found, added a line to redirect RedirectMatch permanent /([a-z0-9\-]+\/)[0-9\/]+ /$1 the Idea was that it would prohibit the numbers in the link. And it worked! All of these references disappeared, and all that before the figures have been tossed on the 404 page.

But... suddenly got a problem.
Mixed Content: The page at 'https://site.ru/' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'site/contact-forms'. This request has been blocked; the content must be served over HTTPS.

ie mixed connection. Removed redirect RedirectMatch permanent /([a-z0-9\-]+\/)[0-9\/]+ /$1 the problem disappears.

Tried to add redirects for http to https does not help...

Help to solve it. I think there are two options.

1) RedirectMatch permanent /([a-z0-9\-]+\/)[0-9\/]+ /$1 or this line as it is to finish.
2) Or in the contact form 7 plugin generates this string 'site/contact-forms'. to change the case. Basically, I found where it is. But I don't know how to change the script.
March 19th 20 at 09:15
0 answer

Find more questions by tags WordPress