Unity error when installing apk after build. How to fix?

After build apk download error when installing:
Syntax error. Error while parsing package

Min api in unity and the manifest match min version installed in the sdk
March 19th 20 at 09:19
1 answer
March 19th 20 at 09:21
Solution
some of the required manifest parameters are not supported in the phone.
gles 2 or 3
api in the manifest 7 from Android and the phone on the 6th.
or something from this. you would rather log in here to copy , and not your own words. there usually says that the parsing of the manifest or something else.
on new projects without a manifest does not work
I tried to put both architectures - Karley.Leusch commented on March 19th 20 at 09:24
"on new projects without a manifest doesn't work "

some of these new projects?? what do you mean?

"I tried to put both architecture"

where to put it? which architectures?? armv7 ?? gles ? not architecture.

and repeat the log from logcat where? what writes when he can't install apk ??) before the project is assembled/installed? empty project collects/sets?))

dig)) search)) what you put. - Skyla commented on March 19th 20 at 09:27
empty collects but does not install as with all - Karley.Leusch commented on March 19th 20 at 09:30
here is the logcat
https://vk.com/doc385383006_496484340 - Karley.Leusch commented on March 19th 20 at 09:33
the Manifesto in the Studio) something finished. and features of the phone. and player seting. skinsation. what sort of API are)

most often . this is an attempt to put the old Android app with minimum API higher than the phone can.

if an empty project without a manifest (and not climbed in default ulatowska did not change anything) - nearly 99 percent that just version SDK messed up. - Skyla commented on March 19th 20 at 09:36
I have installed all SDK api here is what I have in the settings in an empty project without a manifest
5ca0ba4f36320073776118.png5ca0ba5430da0545080550.png5ca0ba59d8a4a690843446.png5ca0ba5d3a733058087905.png - Karley.Leusch commented on March 19th 20 at 09:39
Getting the API level - the most important and interesting place.
just you wait there and POINT what you put the minimum.

do not care what your SDK is in the system.. if you have collected with a minimum target API 26, you this APK never and will never run on an ancient Android. - Skyla commented on March 19th 20 at 09:42
@Skyla,
1 screen after loading the api
2 screen that is thrown in the console after loading
5ca2467466be2845239494.png5ca24678e386b399843171.png - Karley.Leusch commented on March 19th 20 at 09:45
well. weird, at the same nastrojkah seabonay. the only difference is that unity later. 2017 and 2018 versions.
old probably is not very friendly with the new sdk tools from Google.
or try the SDK tools can't find 26.1.1 ,and what some 25.1 or 25.2 to deliver.

or unity to put LTS tighter. 2017.4

so it is clearly not out with one another to make friends. and collects something) it is strange that in this scenario actually collects APK. - Skyla commented on March 19th 20 at 09:48
@Skyla, the sdk tools can't find the old version - Karley.Leusch commented on March 19th 20 at 09:51

Find more questions by tags Unity Game Engine