What to do if it is not installed .NET FRAMEWORK 3.5 on Windows Server 2019?

For work programme need .net framework 3.5 (package with 2.0 and 3.0)! Tried different ways, they all ended in failure. What do I do?! Thank you in advance for the answer!
March 19th 20 at 09:21
2 answers
March 19th 20 at 09:23
Error-what gives? As installed?
Install 4.5, there is already 3.5.
Install 4.5, there is already 3.5.
No. - daphnee commented on March 19th 20 at 09:26
@it, I meant compatibility: https://docs.microsoft.com/ru-ru/dotnet/framework/...
But still, Yes, with exceptions. - dejon84 commented on March 19th 20 at 09:29
Here new screenshots:
5ca067027ad4f422700138.jpeg5ca0670a8fb24122711249.jpeg5ca0671071f34312730780.jpeg - Zackery_Padberg commented on March 19th 20 at 09:32
@dejon84, according to the Mike will work there not 100%, but in General I agree that this may be an option. - daphnee commented on March 19th 20 at 09:35
March 19th 20 at 09:25
Perhaps .net framework 3.5 relies on the implementation of older versions of WinAPI, and the way Windows Server 2019 is not considered

System requirements
Supported Operating System
Windows Server 2003, Windows Server 2008, Windows Vista, Windows XP


You can instead .NET to try to install Mono (first tested locally).
Sponsored by Microsoft, Mono is an open source implementation of Microsoft's .NET Framework based on the ECMA standards for C# and the Common Language Runtime.

Find more questions by tags Windows Server.NETMicrosoft