How to remove the slash at the end of the URL in Nuxt application (SPA mode)?

Use in the project Nuxt.js in SPA mode.

Faced with the problem that when deploying a site on the server (Apache) if you go to one of the internal pages directly, images are not loaded (the paths do not converge).
As I found out, the problem is that the server sees the URL as a link to the directory, not the file, which adds the slash. And the application that in turn loads a file like the link to the page is a file. (in fact it's really a directory, which is index.html with scripts).

Here home - 4dea.ru/works/TEST/spc/
If you click on the link (button in the section "Marine structure") on 4dea.ru/works/TEST/spc/morskie-konstrukcii everything will be in order (as I understand it, because then the server sees the current file as if it is in the root folder). However, if you obnoviti this page (marine structures), then it certainly adds a slash and all the spoils (in the header and below, in the gallery, pictures are not loaded)

Tried to forbid to add a slash in .htaccess (DirectorySlash Off), but then the server process the request can not.
It is noteworthy that on LAN Node.js server slash substitutes and all works well.

Now .htaccess until cleared.

Would like to know how can I solve this problem (without resorting to absolute paths in images)
March 19th 20 at 09:25
1 answer
March 19th 20 at 09:27
Solution
Found two solutions:
1. Instead of href="image.png" set href="/image.png", then all pages will indicate the absolute path of the picture and everything will work as it should. However, this option will not work if the application is not in the root directory of your site.
2. Of assets to load via href="@/assets/image.png". For styles and dynamic ways you can use:
:style="{backgroundImage: `url('${require('@/assets/boat.jpg')}')`}"


Good luck to everyone :)

Find more questions by tags Vue.jshtaccessApacheJavaScript