How to fix docker on windows 10?

Hi all, is the task to run docker on windows 10, this is important because the option of running through VBox does not suit me flatly, and saw the doll do not want (though perhaps there is a way similar to what docker uses the toolbox, I would appreciate your advice)

Installation option installing Docker for Windows me is not satisfied, so using a virtual machine, and disable the virtualization plan. What actually occurs the main problem is the installation DockerToolbox because I understand that it integrates with vbox over, but I still tried to install it, the version 18.09.3 | Stood like all without error, but unfortunately when you run Docker Quickstart Terminal I get the following error:

Conclusion

Running pre-checks create...
Error with the pre-create check: "This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory"
Looks like something went wrong in step Checking if exists default machine... Press any key to continue...

I have to say that VT-X/AMD-I have definitely enabled, as evidenced by even the windows and the hypervisor is disabled. On the stack I was looking for a solution, nothing helped.

Actually the question whether there are alternative methods for using Docker on win10?

p.s try to put on the WSL all through...
Here is what displays when you run docker
WSL
runtime: epollwait on fd 4 failed with 38
fatal error: runtime: netpoll failed

runtime stack:
runtime.throw(0x17e4f70, 0x17)
/usr/local/go/src/runtime/panic.go:616 +0x81
runtime.netpoll(0x158fa7700, 0x7f0e00000000)
/usr/local/go/src/runtime/netpoll_epoll.go:75 +0x216
runtime.sysmon()
/usr/local/go/src/runtime/proc.go:4265 +0x424
runtime.mstart1(0x0)
/usr/local/go/src/runtime/proc.go:1227 +0xe7
runtime.mstart()
/usr/local/go/src/runtime/proc.go:1193 +0x76

goroutine 1 [runnable, locked to thread]:
github.com/docker/cli/vendor/github.com/theupdateframework/notary/tuf.init()
:1 +0xf5

goroutine 5 [syscall]:
os/signal.signal_recv(0x0)
/usr/local/go/src/runtime/sigqueue.go:139 +0xa6
os/signal.loop()
/usr/local/go/src/os/signal/signal_unix.go:22 +0x22
created by os/signal.init.0
/usr/local/go/src/os/signal/signal_unix.go:28 +0x41
March 23rd 20 at 18:47
2 answers
March 23rd 20 at 18:49
Solution
In the bcd boot loader need to enable hyperv
bcdedit /set hypervisorlaunchtype auto

https://blogs.technet.microsoft.com/vm/2008/03/29/19/

Google it is extremely easy on the text from the error:)
Please carefully read the question about the hypervisor I wrote... This is something that Docker does NOT suit me. - Luisa40 commented on March 23rd 20 at 18:52
@Luisa40, we are talking about a virtual machine in hyper-v, open the snap and you will see it. Wsl2 is not out, where there is a nucleus. And in wsl1 kernel does not, then dockerd can not be run!
Of the options only 1 - dev with Linux inside, where it will run dockerd, what is actually done in hyper-v. And this is the recommended method for native virtualization and support from the community or do yourself a Docker, for example, put Vbox/vmvare/anything, negotiates folders inside the vm, then from there volume in containers or rolesto work remotely with the files, put dockerd run... In this version, a lot of manual actions+is not obvious in the form of a tuning environment to run under a specific hypervisor. - maximilian_Rowe1 commented on March 23rd 20 at 18:55
@maximilian_Rowe1, Wsl2 requires hypervisor is honestly a failure. Google - jarod79 commented on March 23rd 20 at 18:58
March 23rd 20 at 18:51
No way. I tried to take the elixir s project dependencies in Docker on Windows, eventually freaked out and put Ubuntu, which basically did not want to climb over 10 years. In the end happy like the Panda. Windu demolished.
Unfortunately I can not do due to the fact that you have to work with graphics, and the same photoshop, for example, normally not working, not to mention Illustrator. Now I will try to put Pro for Workstations, and configure the virtual environment with older versions of vbox and the toolbox, if it all works out then I will unsubscribe mandatory. - Luisa40 commented on March 23rd 20 at 18:54

Find more questions by tags DockerWindowsVirtualBox