How to install the AnyEvent module for Perl?

Axis - Debian
I want to put the module AnyEvent.
Put this kind of team
cpan AnyEvent::Fork::Pool

Gives the error:
MLEHMANN/IO-FDPass-1.2.tar.gz
 Has already been unwrapped into directory /root/.cpan/build/IO-FDPass-1.2-z43rYW
Warning: Prerequisite 'Canary::Stability => 0' for 'MLEHMANN/IO-FDPass-1.2.tar.gz' failed when processing 'MLEHMANN/Canary-Stability-2013.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Configuring M/ML/MLEHMANN/IO-FDPass-1.2.tar.gz with Makefile.PL
Warning: No success on command[/usr/bin/perl Makefile.PL INSTALLDIRS=site]
MLEHMANN/IO-FDPass-1.2.tar.gz
 /usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK
Running install for module 'Proc::FastSpawn'
Checksum for /root/.cpan/sources/authors/id/M/ML/MLEHMANN/Proc-FastSpawn-1.2.tar.gz ok
Configuring M/ML/MLEHMANN/Proc-FastSpawn-1.2.tar.gz with Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Proc::FastSpawn
Writing MYMETA.yml and MYMETA.json
MLEHMANN/Proc-FastSpawn-1.2.tar.gz
 /usr/bin/perl Makefile.PL INSTALLDIRS=site -- OK
Running make for M/ML/MLEHMANN/Proc-FastSpawn-1.2.tar.gz
MLEHMANN/Proc-FastSpawn-1.2.tar.gz
 make -- NOT OK
MLEHMANN/AnyEvent-Fork-1.31.tar.gz
 Has already been unwrapped into directory /root/.cpan/build/AnyEvent-Fork-1.31-PjcNSH
MLEHMANN/AnyEvent-Fork-1.31.tar.gz
 Has already been prepared
Running make for M/ML/MLEHMANN/AnyEvent-Fork-1.31.tar.gz
Warning: Prerequisite 'Proc::FastSpawn => 0.1' for 'MLEHMANN/AnyEvent-Fork-1.31.tar.gz' failed when processing 'MLEHMANN/Proc-FastSpawn-1.2.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'IO::FDPass => 0.2' for 'MLEHMANN/AnyEvent-Fork-1.31.tar.gz' failed when processing 'MLEHMANN/IO-FDPass-1.2.tar.gz' with 'writemakefile => NO '/usr/bin/perl Makefile.PL INSTALLDIRS=site' returned status 512'. Contin
MLEHMANN/AnyEvent-Fork-1.31.tar.gz
 make -- NOT OK
MLEHMANN/AnyEvent-Fork-RPC-1.24.tar.gz
 Has already been unwrapped into directory /root/.cpan/build/AnyEvent-Fork-RPC-1.24-fDLoQr
MLEHMANN/AnyEvent-Fork-RPC-1.24.tar.gz
 Has already been prepared
Running make for M/ML/MLEHMANN/AnyEvent-Fork-RPC-1.24.tar.gz
Warning: Prerequisite 'AnyEvent::Fork => 0.6' for 'MLEHMANN/AnyEvent-Fork-RPC-1.24.tar.gz' failed when processing 'MLEHMANN/AnyEvent-Fork-1.31.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
MLEHMANN/AnyEvent-Fork-RPC-1.24.tar.gz
 make -- NOT OK
Running install for module 'AnyEvent::Fork'
MLEHMANN/AnyEvent-Fork-1.31.tar.gz
 Has already been unwrapped into directory /root/.cpan/build/AnyEvent-Fork-1.31-PjcNSH
MLEHMANN/AnyEvent-Fork-1.31.tar.gz
 Has already been prepared
MLEHMANN/AnyEvent-Fork-1.31.tar.gz
 Could not make: Unknown error

MLEHMANN/AnyEvent-Fork-Pool-1.2.tar.gz
 Has already been unwrapped into directory /root/.cpan/build/AnyEvent-Fork-Pool-1.2-1m1dGf
MLEHMANN/AnyEvent-Fork-Pool-1.2.tar.gz
 Has already been prepared
Running make for M/ML/MLEHMANN/AnyEvent-Fork-Pool-1.2.tar.gz
Warning: Prerequisite 'AnyEvent::Fork => 0.6' for 'MLEHMANN/AnyEvent-Fork-Pool-1.2.tar.gz' failed when processing 'MLEHMANN/AnyEvent-Fork-1.31.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'AnyEvent::Fork::RPC => 0' for 'MLEHMANN/AnyEvent-Fork-Pool-1.2.tar.gz' failed when processing 'MLEHMANN/AnyEvent-Fork-RPC-1.24.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'Task::Weaken => 1' for 'MLEHMANN/AnyEvent-Fork-Pool-1.2.tar.gz' failed when processing 'ETHER/Task-Weaken-1.06.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.
Warning: Prerequisite 'Array::Heap => 3' for 'MLEHMANN/AnyEvent-Fork-Pool-1.2.tar.gz' failed when processing 'MLEHMANN/Array-Heap-3.22.tar.gz' with 'writemakefile => NO '/usr/bin/perl Makefile.PL INSTALLDIRS=site' returned status 512'. C
MLEHMANN/AnyEvent-Fork-Pool-1.2.tar.gz
 make -- NOT OK
March 23rd 20 at 18:59
2 answers
March 23rd 20 at 19:01
Solution
apt-get install build-essential
cpan App::cpanminus
cpanm AnyEvent::Fork::Pool
March 23rd 20 at 19:03
For pearl, as a rule, there are ready-made binaries of the modules. Something heavy that requires a lot of tests during installation easier to install via apt.
apt install libanyevent-perl

Find more questions by tags multithreadingPerl