Error install nginx/php-fpm, how to fix?

Work with a RaspberryPi Model 3B.
Set nginx and php the guide from Grav: https://getgrav.org/blog/raspberrypi-nginx-php7-dev
Decided to use a guide, because the old way(apt install nginx php-fpm) gave an error.
As it turned out, I'm not the problem, the problem is somewhere inside.
Put team
pi@raspi ~ sudo apt-get install -t buster php7.2 php7.2-curl php7.2-gd php7.2-fpm php7.2-cli php7.2-opcache php7.2-mbstring php7.2-xml php7.2-zip

Everything is downloaded, unpacked, but when setting up vybivaet error:
Log

Creating config file /etc/php/7.2/fpm/php.ini with new version
Created symlink /etc/systemd/system/multi-user.target.wants/php7.2-fpm.service → /lib/systemd/system/php7.2-fpm.service.
Job for php7.2-fpm.service failed because the control process exited with error code.
See "systemctl status php7.2-fpm.service" and "journalctl -xe" for details.
invoke-rc.d: initscript php7.2-fpm, action "start" failed.
● php7.2-fpm.service - The PHP FastCGI Process Manager 7.2
 Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
 Active: failed (Result: exit-code) since Tue 2019-06-04 20:00:52 +07; 36ms ago
 Docs: man:php-fpm7.2(8)
 Process: 8667 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize --fpm-config /etc/php/7.2/fpm/php-fpm.conf (code=exited, status=127)
 Main PID: 8667 (code=exited, status=127)

Jun 04 20:00:52 raspi systemd[1]: Starting The PHP FastCGI Process Manager 7.2...
Jun 04 20:00:52 raspi php-fpm7.2[8667]: [122B blob data]
Jun 04 20:00:52 raspi systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=127/n/a
Jun 04 20:00:52 raspi systemd[1]: Failed to start The PHP FastCGI Process Manager 7.2.
Jun 04 20:00:52 raspi systemd[1]: php7.2-fpm.service: Unit entered failed state.
Jun 04 20:00:52 raspi systemd[1]: php7.2-fpm.service: Failed with result 'exit-code'.
dpkg: error processing package php7.2-fpm (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of php7.2:
 php7.2 depends on libapache2-mod-php7.2 | php7.2-fpm | php7.2-cgi; however:
 Package libapache2-mod-php7.2 is not installed.
 Package php7.2-fpm is not configured yet.
 Package php7.2-cgi is not installed.

dpkg: error processing package php7.2 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for systemd (232-25+deb9u11) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
php7.2-fpm
php7.2
E: Sub-process /usr/bin/dpkg returned an error code (1)



systemctl status php7.2-fpm.service

✘ pi@raspi ~ systemctl status php7.2-fpm.service
● php7.2-fpm.service - The PHP FastCGI Process Manager 7.2
 Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
 Active: failed (Result: exit-code) since Tue 2019-06-04 20:00:52 +07; 3min 24s ago
 Docs: man:php-fpm7.2(8)
 Main PID: 8667 (code=exited, status=127)

Jun 04 20:00:52 raspi systemd[1]: Starting The PHP FastCGI Process Manager 7.2...
Jun 04 20:00:52 raspi php-fpm7.2[8667]: [122B blob data]
Jun 04 20:00:52 raspi systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=127/n/a
Jun 04 20:00:52 raspi systemd[1]: Failed to start The PHP FastCGI Process Manager 7.2.
Jun 04 20:00:52 raspi systemd[1]: php7.2-fpm.service: Unit entered failed state.
Jun 04 20:00:52 raspi systemd[1]: php7.2-fpm.service: Failed with result 'exit-code'.



`journalctl -xe` gives out only sshd and kernel, anything related to apt or php no.
When you run php-v gives this:
✘ pi@raspi ~ php-v
php: error while loading shared libraries: ☻7�: cannot open shared object file: No such file or directory

Very surprised by this sequence of characters, because it is of course important, but anything from it is not clear.
Installing nginx and also it gives nothing:
✘ pi@raspi ~ sudo apt install nginx-full nginx

✘ pi@raspi ~ sudo apt install nginx-full nginx
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nginx-full : Depends: libnginx-mod-http-auth-pam (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-http-dav-ext (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-http-echo (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-http-geoip (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-http-image-filter (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-http-subs-filter (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-http-upstream-fair (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-http-xslt-filter (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-mail (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: libnginx-mod-stream (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
 Depends: nginx-common (= 1.10.3-1+deb9u2) but 1.14.2-2 is to be installed
E: Unable to correct problems, you have held broken packages.


However, it becomes clear that we have held broken packages, but why broken - not clear.
March 23rd 20 at 19:03
1 answer
March 23rd 20 at 19:05
php7.2 depends on libapache2-mod-php7.2 | php7.2-fpm | php7.2-cgi; however:
 Package libapache2-mod-php7.2 is not installed.
 Package php7.2-fpm is not configured yet.
 Package php7.2-cgi is not installed.

add to install libapache2-mod-php7.2 and php7.2-cgi
All the same
Log
The following NEW packages will be installed:
php7.2-fpm
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,158 kB of archives.
After this operation, 3,577 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Selecting previously unselected package php7.2-fpm.
(Reading database ... 38619 files and directories currently installed.)
Preparing to unpack .../php7.2-fpm_7.2.9-1+b2_armhf.deb ...
Unpacking php7.2-fpm (7.2.9-1+b2) ...#####..........................................................................................................................]
Setting up php7.2-fpm (7.2.9-1+b2) ...#####################################################.........................................................................]
Progress: [ 66%] [#################################################################################################.................................................]
Creating config file /etc/php/7.2/fpm/php.ini with new version
NOTICE: Not enabling PHP 7.2 FPM by default.
NOTICE: To enable PHP in Apache2 7.2 FPM do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.2-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Created symlink /etc/systemd/system/multi-user.target.wants/php7.2-fpm.service → /lib/systemd/system/php7.2-fpm.service.
Job for php7.2-fpm.service failed because the control process exited with error code.
See "systemctl status php7.2-fpm.service" and "journalctl -xe" for details.
invoke-rc.d: initscript php7.2-fpm, action "start" failed.
● php7.2-fpm.service - The PHP FastCGI Process Manager 7.2
 Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
 Active: failed (Result: exit-code) since Tue 2019-06-04 21:21:18 +07; 35ms ago
 Docs: man:php-fpm7.2(8)
 Process: 18166 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize --fpm-config /etc/php/7.2/fpm/php-fpm.conf (code=exited, status=127)
 Main PID: 18166 (code=exited, status=127)

Jun 04 21:21:18 raspi systemd[1]: Starting The PHP FastCGI Process Manager 7.2...
Jun 04 21:21:18 raspi php-fpm7.2[18166]: [122B blob data]
Jun 04 21:21:18 raspi systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=127/n/a
Jun 04 21:21:18 raspi systemd[1]: Failed to start The PHP FastCGI Process Manager 7.2.
Jun 04 21:21:18 raspi systemd[1]: php7.2-fpm.service: Unit entered failed state.
Jun 04 21:21:18 raspi systemd[1]: php7.2-fpm.service: Failed with result 'exit-code'.
dpkg: error processing package php7.2-fpm (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for systemd (232-25+deb9u11) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
php7.2-fpm
E: Sub-process /usr/bin/dpkg returned an error code (1)

- Maymie_White commented on March 23rd 20 at 19:08

Find more questions by tags RaspbianRaspberry PiPHP