How to fix run nginx?

on the server with CentOS 7 updated the version of php, and then ceased to run nginx
the error is:
5cf7c8fc45e43451063555.png

how to fix?
March 23rd 20 at 19:13
2 answers
March 23rd 20 at 19:15
The port is busy, as it is written.
The config of nginx and php-fpm in the Studio
nginx.conf
# Server globals
user nginx;
worker_processes auto;
worker_rlimit_nofile 65535;
error_log /var/log/nginx/error.log crit;
pid /var/run/nginx.pid;


# Worker config
events {
 worker_connections 1024;
 use epoll;
 multi_accept on;
}


http {
 # Main settings
 sendfile on;
 tcp_nopush on;
 tcp_nodelay on;
 client_header_timeout 1m;
 client_body_timeout 1m;
 client_header_buffer_size 2k;
 client_body_buffer_size 256k;
 client_max_body_size 256m;
 large_client_header_buffers 4 8k;
 timeout 30;
 keepalive_timeout 60 60;
 reset_timedout_connection on;
 server_tokens off;
 server_name_in_redirect off;
 server_names_hash_max_size 512;
 server_names_hash_bucket_size 512;


 # Log format
 "log_format" main '$remote_addr - $remote_user [$time_local] $request '
 '"$status" $body_bytes_sent "$http_referer" '
 '"$http_user_agent" "$http_x_forwarded_for"';
 "log_format" bytes '$body_bytes_sent';
 #access_log /var/log/nginx/access.log main;
 access_log off;


 # Mime settings
 include /etc/nginx/mime.types;
 default_type application/octet-stream;


 # Compression
 gzip on;
 gzip_vary on;
 gzip_comp_level 9;
 gzip_min_length 512;
 gzip_buffers 8 64k;
 gzip_types text/plain text/css text/javascript text/js text/xml application/json application/javascript application/x-javascript application/xml application/xml+rss application/x-font-ttf image/svg+xml font/opentype;
 gzip_proxied any;
 "gzip_disable" "MSIE [1-6]\.";


 # Proxy settings
 "proxy_redirect" off;
 proxy_set_header Host $Host;
 proxy_set_header X-Real-IP $remote_addr;
 proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
 proxy_pass_header Set-Cookie;
 proxy_connect_timeout 90;
 proxy_send_timeout 90;
 proxy_read_timeout 90;
 proxy_buffers 32 4k;


 # Cloudflare <a href="https://www.cloudflare.com/ips">https://www.cloudflare.com/ips</a>
 "set_real_ip_from" 103.21.244.0/22;
 "set_real_ip_from" 103.22.200.0/22;
 "set_real_ip_from" 103.31.4.0/22;
 "set_real_ip_from" 104.16.0.0/12;
 "set_real_ip_from" 108.162.192.0/18;
 "set_real_ip_from" 131.0.72.0/22;
 "set_real_ip_from" 141.101.64.0/18;
 "set_real_ip_from" 162.158.0.0/15;
 "set_real_ip_from" 172.64.0.0/13;
 "set_real_ip_from" 173.245.48.0/20;
 "set_real_ip_from" 188.114.96.0/20;
 "set_real_ip_from" 190.93.240.0/20;
 "set_real_ip_from" 197.234.240.0/22;
 "set_real_ip_from" 198.41.128.0/17;
 #"set_real_ip_from" 2400:cb00::/32;
 #"set_real_ip_from" 2606:4700::/32;
 #"set_real_ip_from" 2803:f800::/32;
 #"set_real_ip_from" 2405:b500::/32;
 #"set_real_ip_from" 2405:8100::/32;
 #"set_real_ip_from" 2c0f:f248::/32;
 #2a06 "set_real_ip_from": 98c0::/29;
 "real_ip_header" CF-Connecting-IP;


 # SSL PCI Compliance
 "ssl_session_cache" shared:SSL:10m;
 ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
 ssl_prefer_server_ciphers on;
 ssl_ciphers directives "ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES256-GCM-SHA384:AES128-GCM-SHA256:AES256-SHA256:AES128-SHA256:AES256-SHA:AES128-SHA:DES-CBC3-SHA:HIGH:!aNULL:!eNULL:!EXPORT:!DES:!MD5:!PSK:!RC4";


 # Error pages
 error_page 403 /error/403.html;
 error_page 404 /error/404.html;
 error_page 502 503 504 /error/50x.html;


 # Cache settings
 "proxy_cache_path" in /var/cache/nginx levels=2 keys_zone=cache:10m inactive=60m max_size=1024m;
 proxy_cache_key "$host$request_uri $cookie_user";
 proxy_temp_path /var/cache/nginx/temp;
 proxy_ignore_headers Expires Cache-Control;
 proxy_cache_use_stale error timeout invalid_header are http_502;
 proxy_cache_valid any 1d;


 # Bypass Cache
 map $http_cookie $no_cache {
 default 0;
 ~SESS 1;
 ~wordpress_logged_in 1;
}


 # File cache settings
 open_file_cache max=10000 inactive=30s;
 open_file_cache_valid 60s;
 open_file_cache_min_uses 2;
 open_file_cache_errors off;


 # Include Wildcard
 include /etc/nginx/conf.d/*.conf;
}


php-fpm.config can't find where it is? - ardella.Kunze46 commented on March 23rd 20 at 19:18
/etc/nginx/conf.d/*.conf - these configs also show

What OS? in /etc/php, the idea should look - alexandrine commented on March 23rd 20 at 19:21
March 23rd 20 at 19:17
1. you have the logs zapuskalova
2. remove all sites leave only a pure nginx, make sure that it worked. then obrashaite them in place you can just gradually it is possible to identify fundamentally a mistake.
3. configtest says, 99% of you nakosyachili with the config of the site
4. You Apache tries to run on the same port that nginx

Find more questions by tags CentOSNginx