Why after migrating from Apache module to CGI VPS is running normally?

Keep another website on the VPS. Recently when I download pictures got http error. I've been thinking, what's the problem... And access rights checked and the server was rebooted and re-installed WP, in General, did everything! Nothing, as there was a bug and left. Don't know why, but my friend suddenly decided to change the working mode of PHP from Apache module to CGI and... Oh gods! It worked! Neither I nor he do not know what it involves. Vsch why we did it, but it worked. I was wondering why. Who in this topic for a long time, tell pzhlst
March 23rd 20 at 19:18
2 answers
March 23rd 20 at 19:20
Solution
1. in the config there was some shitty Directive when changing the view tag you peruginelli config, in consequence of this, the problem went away.
2. The CGI in your case I think you were stoned and you have FastCGI or PHP-FPM
in fact the whole of this family do not work in .all htaccess php_flag, php_admin_value, php_admin_flag
As a consequence of this could be mistakes for example php_admin_value session.save_path = was the default and not the one that .htaccess
3. different versions of php, when you change the view php could be replaced and the version of php posklku it uchavstvuyut completely different settings, and even kompreni in different folders.
March 23rd 20 at 19:22
Solution
Usually the Apache default mode mpm-prefork. In this mode, most buggy and incorrect mode of operation mod_php. So if you want to use mod_php, then choose the modes mpm-itk or mod_ruid2.
More or less universal mode is PHP-FPM.

Find more questions by tags ApachePHP