Why not get serikbaevich jwt-auth in larado project?

linux mint 19
docker - 18.09.6
docker-compose - 1.24.0
mysql 8
laravel - 5.8.19
composer - 1.8.5

I go to the workspace using
docker-compose --exec user=laradock workspace bash

trying to pull jwt-auth and there is some kind of game.

laradock@195def44f1f0:/var/www$ composer require tymon/jwt-auth
Using version ^0.5.12 for tymon/jwt-auth
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

 Problem 1
 - Installation request for tymon/jwt-auth ^0.5.12 -> satisfiable by tymon/jwt-auth[0.5.12].
 - Conclusion: remove nesbot/carbon 2.19.0
 - Conclusion: don't install nesbot/carbon 2.19.0
 - tymon/jwt-auth-0.5.12 requires nesbot/carbon ~1.0 -> satisfiable by nesbot/carbon[1.0.0, 1.0.1, 1.1.0, 1.10.0, 1.11.0, 1.12.0, 1.13.0, 1.14.0, 1.15.0, 1.16.0, 1.17.0, 1.18.0, 1.19.0, 1.2.0, 1.20.0, 1.21.0, 1.22.0, 1.22.1, 1.23.0, 1.24.0, 1.24.1, 1.24.2, 1.25.0, 1.25.1, 1.25.3, 1.26.0, 1.26.1, 1.26.2, 1.26.3, 1.26.4, 1.26.5, 1.26.6, 1.27.0, 1.28.0, 1.29.0, 1.29.1, 1.29.2, 1.3.0, 1.30.0, 1.31.0, 1.31.1, 1.32.0, 1.33.0, 1.34.0, 1.34.1, 1.34.2, 1.34.3, 1.34.4, 1.35.0, 1.35.1, 1.36.0, 1.36.1, 1.36.2, 1.37.0, 1.37.1, 1.38.0, 1.38.1, 1.38.2, 1.38.3, 1.38.4, 1.4.0, 1.5.0, 1.6.0, 1.7.0, 1.8.0, 1.9.0].
 - Can only install one of: nesbot/carbon[1.26.3, 2.19.0].
 - Can only install one of: nesbot/carbon[1.26.4, 2.19.0].
 - Can only install one of: nesbot/carbon[1.26.5, 2.19.0].
 - Can only install one of: nesbot/carbon[1.26.6, 2.19.0].
 - Can only install one of: nesbot/carbon[1.27.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.28.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.29.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.29.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.29.2, 2.19.0].
 - Can only install one of: nesbot/carbon[1.30.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.31.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.31.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.32.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.33.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.34.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.34.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.34.2, 2.19.0].
 - Can only install one of: nesbot/carbon[1.34.3, 2.19.0].
 - Can only install one of: nesbot/carbon[1.34.4, 2.19.0].
 - Can only install one of: nesbot/carbon[1.35.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.35.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.36.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.36.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.36.2, 2.19.0].
 - Can only install one of: nesbot/carbon[1.37.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.37.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.38.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.38.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.38.2, 2.19.0].
 - Can only install one of: nesbot/carbon[1.38.3, 2.19.0].
 - Can only install one of: nesbot/carbon[1.38.4, 2.19.0].
 - Can only install one of: nesbot/carbon[1.0.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.0.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.1.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.10.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.11.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.12.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.13.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.14.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.15.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.16.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.17.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.18.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.19.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.2.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.20.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.21.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.22.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.22.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.23.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.24.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.24.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.24.2, 2.19.0].
 - Can only install one of: nesbot/carbon[1.25.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.25.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.25.3, 2.19.0].
 - Can only install one of: nesbot/carbon[1.26.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.26.1, 2.19.0].
 - Can only install one of: nesbot/carbon[1.26.2, 2.19.0].
 - Can only install one of: nesbot/carbon[1.3.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.4.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.5.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.6.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.7.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.8.0, 2.19.0].
 - Can only install one of: nesbot/carbon[1.9.0, 2.19.0].
 - Installation request for nesbot/carbon (locked at 2.19.0) -> satisfiable by nesbot/carbon[2.19.0].


Installation failed, reverting ./composer.json to its original content.


Tell me how to fix this problem?
March 23rd 20 at 19:19
1 answer
March 23rd 20 at 19:21
Solution
installed version 1, like the rules, but now the other stuff: composer update issues
[RuntimeException] 
 Could not delete /var/www/vendor/bin/var-dump-server:

5cf99694d347a394629733.png

I don't understand, it tries to remove "beyondcode/laravel-dump-server": "^1.0",which lies in the require-dev section? What's going on : ( - Jaquan_Wintheiser39 commented on March 23rd 20 at 19:24
here composer.json
{
 "name": "laravel/laravel",
 "type": "project",
 "description": "The Laravel Framework.",
 "keywords": [
"framework"
"laravel"
],
 "license": "MIT",
 "require": {
 "php": "^7.1.3",
 "fideloper/proxy": "^4.0",
 "laravel/framework": "5.8.*",
 "laravel/tinker": "^1.0",
"tymon/jwt-auth":"^1.0"
},
 "require-dev": {
 "beyondcode/laravel-dump-server": "^1.0",
 "filp/whoops": "^2.0",
 "fzaninotto/faker": "^1.4",
 "mockery/mockery": "^1.0",
 "nunomaduro/collision": "^3.0",
 "phpunit/phpunit": "^7.5"
},
 "config": {
 "optimize-autoloader": true,
 "preferred-install": "dist",
 "sort-packages": true
},
 "extra": {
 "laravel": {
 "dont-discover": []
}
},
 "autoload": {
 "psr-4": {
 "App\\": "app/"
},
 "classmap": [
"database/seeds",
"database/factories"
]
},
 "autoload-dev": {
 "psr-4": {
 "Tests\\": "tests/"
}
},
 "minimum-stability": "dev",
 "prefer-stable": true,
 "scripts": {
 "post-autoload-dump": [
"Illuminate\\Foundation\\ComposerScripts::postAutoloadDump",
 "@php artisan package:discover --ansi"
],
 "post-root-package-install": [
 "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
],
 "post-create-project-cmd": [
 "@php artisan key:generate --ansi"
]
}
}
- Jaquan_Wintheiser39 commented on March 23rd 20 at 19:27
most likely you are not the correct permissions chmod and chown on the folder vendor and other, what precisely I will not tell, but I can see in Google

for a more visual debug you can use the command
composer update -vvv - jason79 commented on March 23rd 20 at 19:30
@jason79, got a trace
Exception trace:
 () at phar:///usr/local/bin/composer/src/Composer/Util/Filesystem.php:211
 Composer\Util\Filesystem->unlink() at phar:///usr/local/bin/composer/src/Composer/Installer/BinaryInstaller.php:108
 Composer\Installer\BinaryInstaller->removeBinaries() at phar:///usr/local/bin/composer/src/Composer/Installer/LibraryInstaller.php:119
 Composer\Installer\LibraryInstaller->update() at phar:///usr/local/bin/composer/src/Composer/Installer/InstallationManager.php:193
 Composer\Installer\InstallationManager->update() at phar:///usr/local/bin/composer/src/Composer/Installer/InstallationManager.php:160
 Composer\Installer\InstallationManager->execute() at phar:///usr/local/bin/composer/src/Composer/Installer.php:595
 Composer\Installer->doInstall() at phar:///usr/local/bin/composer/src/Composer/Installer.php:229
 Composer\Installer->run() at phar:///usr/local/bin/composer/src/Composer/Command/UpdateCommand.php:162
 Composer\Command\UpdateCommand->execute() at phar:///usr/local/bin/composer/vendor/symfony/console/Command/Command.php:245
 Symfony\Component\Console\Command\Command->run() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:835
 Symfony\Component\Console\Application->doRunCommand() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:185
 Symfony\Component\Console\Application->doRun() at phar:///usr/local/bin/composer/src/Composer/Console/Application.php:258
 Composer\Console\Application->doRun() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:117
 Symfony\Component\Console\Application->run() at phar:///usr/local/bin/composer/src/Composer/Console/Application.php:104
 Composer\Console\Application->run() at phar:///usr/local/bin/composer/bin/composer:56
 require() at /usr/local/bin/composer:24
- Jaquan_Wintheiser39 commented on March 23rd 20 at 19:33
I'm just a beginner in docker, I installed according to the tutorial

he was there only gave rights to storage and bootstrap/cache
sudo chmod-R 777 storage bootstrap/cache

Maybe he forget something? - Jaquan_Wintheiser39 commented on March 23rd 20 at 19:36
@beefjerky, error composer, Google this: https://stackoverflow.com/questions/26216437/error... - jason79 commented on March 23rd 20 at 19:39
@jason79, in short, you need to do sudo chmod-R 777 folder(file) and all the rules. - Jaquan_Wintheiser39 commented on March 23rd 20 at 19:42
you need to give write permissions to the directories and files to which the framework may change at the request of the developer, that is, app, bootstrap, config, storage, vendor, .env, maybe something else. - Jaquan_Wintheiser39 commented on March 23rd 20 at 19:45

Find more questions by tags Composer