As for polylang to display the icons correctly?

All the best!
Dear experts, prompt, how do I configure the plugin polylang under the following tasks:
The site appears in Russian language in the menu one icon should be displayed in the form of the British flag (if you want to translate to English).
After clicking on it, the site appears in English, and an icon in the form of the Russian flag.
Now, in fact, such a situation:
Site in Russian, icon of the British flag, the old icon is still the British flag...
In other words, now the icon does not change...
Tell me how to fix this mess?
Thank you.
March 23rd 20 at 19:27
2 answers
March 23rd 20 at 19:29
 'hide_current' => true,
 'show_flags' => true,
 'show_names' => false

In the place where you want to display the flag.
Thank you! Almost works :)
All appears as it should, only after reloading the page... - Friedrich_Crooks20 commented on March 23rd 20 at 19:32
@Friedrich_Crooks20, to change the language in any case, the page will reload and depending on your settings changed or slug of language with /EN/ to /en/ or option ?lang=EN ?lang=en. Or I something do not understand? - thurman commented on March 23rd 20 at 19:35
@thurman, Yuri, thank you for participating in the conversation!
In General the impression that the cache inserts his 5 cents.
Step by step the following happens:
1) content in the Russian language, the flag of Britain.
2) Click on the flag of Britain, the page refreshes, the content is displayed in English, but the flag still British.
3) press Ctrl F5, the page refreshes, displays the flag of the Russian...
that's what I was trying to describe. - Friedrich_Crooks20 commented on March 23rd 20 at 19:38
@Friedrich_Crooks20, not experienced with this, try to disable the plugins related to caching and see whether the problem is solved. Also to solve the problem I recommend to contact the official support forum - thurman commented on March 23rd 20 at 19:41
March 23rd 20 at 19:31
Out of the box it all works fine, you can find the error in my implementation. Guess it's hard, can take you through the styles icon added may have created a directory with custom files, and there is no EN flag or a mistake in the name.. And perhaps stupidly in the plugin settings you chose the wrong flag or not choose?
Thanks for your answer!
I may not correctly stated his Myst...
The point is that the flags in principle appear in the drop-down list, and if in the plugin settings, to do that would have both flags displayed in the menu bar...
My job was to make sure that the flag was displayed one.
And showed the language, which you can switch.
ie if the content is in Russian, the flag Doelen hanging by the British If the content in English, then the flag should be hung Russian... BUT what if it was one flag. - Friedrich_Crooks20 commented on March 23rd 20 at 19:34
@Friedrich_Crooks20, and well, Yes, there had been add 'hide_current' => True, but above you suggested. - Lucas commented on March 23rd 20 at 19:37

Find more questions by tags WordPress