When accessing via telnet to the server gives "HTTP/1.1 400 Bad Request" what is the mistake?

Hello !
1. In the command prompt OS gain "telnet phpwiki.ru 80". The connection to phpwiki.ru
2. In the utility "telnet" (dialogum opened the window) type "GET / HTTP/1.0". Press ENTER.
3. Issued a "HTTP/1.1 400 Bad Request"

5cfa692adce65393163287.png
March 23rd 20 at 19:32
1 answer
March 23rd 20 at 19:34
telnet phpwiki.ru 80
GET / HTTP/1.1
Host: phpwiki.ru
Copy GET / HTTP/1.1
Host: phpwiki.ru

Insert into "telnet" - a window utility closes. Dial manually, press "Enter" 2 times - the window is closed. Something does not work. - elys commented on March 23rd 20 at 19:37
@elys, I checked (insert pre-typed and copied text), now I tried to enter from the keyboard (blindly) — this way and that everything works. - telly66 commented on March 23rd 20 at 19:40
@telly66, Thank you. At first, did not work. Then I tried after

1. In OS command prompt type "telnet phpwiki.ru 80". The connection to phpwiki.ru

dial ctrl-], saw the invitation Microsoft Telnet> and again hit enter to log in to echo. So now all that typing - can be seen in the window of the utility.
If you re-copy and paste - the same result - flashed the text "bad request" and the window closes. If you enter manually, everything is OK.
In "blind" mode - too all turned out. The snag was that instead of a "dot" pressed "/" and the window immediately closed. But ! Why copying never really worked out - and has remained a mystery ............... - elys commented on March 23rd 20 at 19:43

Find more questions by tags Telnet