What you need NAT for Asterisk?

Asterisk 15
huawei 171 outgoing work.
What NAT add or another problem?

when an incoming call in the log:

[Nov 6 10:09:06] WARNING[3396][C-0000000b] channel.c:215 channel_request: [dongle0] Request to call on device which can not make call at this moment
[Nov 6 10:09:06] WARNING[3396][C-0000000b]: app_dial.c:2510 dial_exec_full: Unable to create channel of type 'Dongle' (cause 44 - Requested channel not available)


dongle show devices
ID Group State RSSI Mode Submode Provider Name Model Firmware IMEI IMSI Number
dongle0 0 GSM not re 23 5 4 E173 MegaFon RUS 11.126.85.00.209 35************ 2501******** +7996********


OpenWrt*CLI> dongle show device settings dongle0
------------- Settings ------------
 Device : dongle0
 Audio : /dev/ttyUSB1
 Data : /dev/ttyUSB2
 IMEI : 35466***************
 IMSI : 2501****************
 Channel Language : en
 Context : default
 Exten :
 Group : 0
 RX gain : 3
 TX gain : 3
 U2Diag : -1
 Use CallingPres : Yes
 Default CallingPres : Presentation Allowed, Passed Screen
 Auto delete SMS : No
 Disable SMS : No
 Reset Dongle : Yes
 SMS PDU : No
 Call Waiting : auto
 DTMF : relax
 Minimal DTMF Gap : 45
 Minimal DTMF Duration : 80
 Minimal DTMF Interval : 200
 Initial device state : start


sip.conf
[general]
allowguest=yes
context=public
localnet=192.168.0.1/255.255.0.0

[111]
type=friend
host=dynamic
secret=111
context=default
canreinvite=yes
dtmfmode=rfc2833
permit=0.0.0.0/0.0.0.0
qualify=yes


extensions.conf

; directory location of this file: /etc/asterisk

[globals]

[general]
static=yes
writeprotect=yes
autofallthrough=yes

[default]
exten => 111, 1, Dial(SIP/111)
exten => 222, 1, Dial(SIP/222)
exten => 333, 1, Dial(SIP/333)
exten => 444, 1, Dial(SIP/444)

exten => _7X.,1,Dial(Dongle/dongle0/holdother:+${FILTER(0-9,${EXTEN})})
exten => _+7X.,1,Dial(Dongle/dongle0/holdother:+${FILTER(0-9,${EXTEN})})
exten => _8X.,1,Dial(Dongle/dongle0/holdother:+7${FILTER(0-9,${EXTEN:1})})
exten => _007X.,1,Dial(Dongle/dongle0/holdother:+7${FILTER(0-9,${EXTEN:3})})
exten => h,1,Hangup()

[dongle-incoming-sms]
exten => sms,1,Noop(Incoming SMS from ${CALLERID(num)} ${BASE64_DECODE(${SMS_BASE64})})
exten => sms,n,System(echo '${STRFTIME(${EPOCH},,%Y-%m-%d %H:%M:%S)} ... ${DONGLENAME} ... ${CALLERID(num)}: ${BASE64_DECODE(${SMS_BASE64})}' >> /var/log/asterisk/sms.t
exten => sms,n,Hangup()

[dongle-incoming-ussd]
exten => ussd,1,Noop(Incoming USSD: ${BASE64_DECODE(${USSD_BASE64})})
exten => ussd,n,System(echo '${STRFTIME(${EPOCH},,%Y-%m-%d %H:%M:%S)} ... ${DONGLENAME}: ${BASE64_DECODE(${USSD_BASE64})}' >> /var/log/asterisk/ussd.txt)
exten => ussd,n,Hangup()

[dongle-incoming]
include => dongle-incoming-sms
include => dongle-incoming-ussd

exten => _X.,1,Dial(SIP/111)
exten => h,1,Hangup()
April 3rd 20 at 17:21
1 answer
April 3rd 20 at 17:23
GSM not ready status.
The assumption of two - either you have a bad SIM card or you need to disable the other modes of the dongle, in addition to GSM. In Huawei modem unlocked off cd & usb mass storage
it's already fixed, just does not work - vernie_Nolan commented on April 3rd 20 at 17:26

Find more questions by tags AsteriskSIPHuaweiOpenWrt