React native version mismatch, why?

5df00b58b8493579670112.png
I cleaned the cache, re-installed react to the version of nodejs, like this expo on the emulator and npm. Failed.
On stackoverflow advised me to close the terminal with bundlом and make expo run again, but then the app refuses to run what was to be expected: it can't start without the js bundle.
April 3rd 20 at 17:23
1 answer
April 3rd 20 at 17:25
Solution
Remove forever the Expo and put react-native cli
https://medium.com/@playra/react-native-init-vs-ex...
Why? - Retha_Welch13 commented on April 3rd 20 at 17:28
@Retha_Welch13, then, what I know from experience will be much less of a problem - carlie.Kle commented on April 3rd 20 at 17:31
@carlie.Kle, but I will. ebrowska, for me, to allow easier - Retha_Welch13 commented on April 3rd 20 at 17:34
@Retha_Welch13, so all I think when just starting out. Sooner or later, you will have to go on react-native-cli, for obvious reasons you think, and you will be with Luggage ebrowski solutions that will not nudzhny more at all! - carlie.Kle commented on April 3rd 20 at 17:37
@carlie.Kle, okay, at first I also react with cli wanted, but the problem was that when you try to run the application, the project hung on the creation of bundlerа. The decision was reinstalare watchmana, which did not produce results. To change the code in default can for newpage a terrible thing. Besides, I've gone too far and fear a lot to lose. What do I do now? (Inb4: Google the solution or create a new question) - Retha_Welch13 commented on April 3rd 20 at 17:40
@Retha_Welch13do Not understand. You can't vanish proctitis created with react native cli? - carlie.Kle commented on April 3rd 20 at 17:43
@carlie.Kle, I can, of course, but hurt node_modules and builds. And it is too late to do pool. - Retha_Welch13 commented on April 3rd 20 at 17:46
@carlie.Kle, well, I started using the react-native-cli, but not yet quite understand, gugleniya for me is useless. In such a situation usually do?

error
error Failed to install the app. Make sure you have the Android development environment set up: https://facebook.github.io/react-native/docs/getti... Run the CLI with --verbose flag for more details.
Error: Command failed: ./gradlew app:installDebug -PreactNativeDevServerPort=8081

FAILURE: Build failed with an exception.

* What went wrong:
Could not determine the dependencies of task ':unimodules-react-native-adapter:compileDebugAidl'.
> Could not resolve all dependencies for configuration of task ':unimodules-react-native-adapter:debugCompileClasspath'.
> Could not resolve androidx.core:core:1.0.0.
Required by:
project :unimodules-react-native-adapter
> Cannot find a version of 'androidx.core:core' that satisfies the version constraints:
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.facebook.react:react native:0.61.5' --> 'androidx.appcompat:appcompat:1.0.2' --> 'androidx.core:core:1.0.1'
...


> Could not resolve androidx.vectordrawable:vectordrawable:1.0.0.
Required by:
project :unimodules-react-native-adapter
> Cannot find a version of 'androidx.vectordrawable:vectordrawable' that satisfies the version constraints:
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.vectordrawable:vectordrawable-animated:1.0.0' --> 'androidx.vectordrawable:vectordrawable:1.0.0'

...
> Could not resolve androidx.core:core:1.0.0.
Required by:
project :unimodules-react-native-adapter > androidx.fragment:fragment:1.0.0
project :unimodules-react-native-adapter > androidx.legacy:legacy-support-core-ui:1.0.0
project :unimodules-react-native-adapter > androidx.legacy:legacy-support-core-utils:1.0.0
project :unimodules-react-native-adapter > androidx.loader:loader:1.0.0
project :unimodules-react-native-adapter > androidx.vectordrawable:vectordrawable:1.0.1
project :unimodules-react-native-adapter > androidx.customview:customview:1.0.0
project :unimodules-react-native-adapter > androidx.viewpager:viewpager:1.0.0
project :unimodules-react-native-adapter > androidx.coordinatorlayout:coordinatorlayout:1.0.0
project :unimodules-react-native-adapter > androidx.drawerlayout:drawerlayout:1.0.0
project :unimodules-react-native-adapter > androidx.slidingpanelayout:slidingpanelayout:1.0.0
project :unimodules-react-native-adapter > androidx.swiperefreshlayout:swiperefreshlayout:1.0.0
project :unimodules-react-native-adapter > androidx.asynclayoutinflater:asynclayoutinflater:1.0.0
> Cannot find a version of 'androidx.core:core' that satisfies the version constraints:
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.facebook.react:react native:0.61.5' --> 'androidx.appcompat:appcompat:1.0.2' --> 'androidx.core:core:1.0.1'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-ui:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-utils:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.loader:loader:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.vectordrawable:vectordrawable-animated:1.0.0' --> 'androidx.vectordrawable:vectordrawable:1.0.1' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.facebook.react:react native:0.61.5' --> 'androidx.appcompat:appcompat:1.0.2' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-ui:1.0.0' --> 'androidx.customview:customview:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-ui:1.0.0' --> 'androidx.viewpager:viewpager:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-ui:1.0.0' --> 'androidx.coordinatorlayout:coordinatorlayout:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-ui:1.0.0' --> 'androidx.drawerlayout:drawerlayout:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-ui:1.0.0' --> 'androidx.slidingpanelayout:slidingpanelayout:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-ui:1.0.0' --> 'androidx.swiperefreshlayout:swiperefreshlayout:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.legacy:legacy-support-core-ui:1.0.0' --> 'androidx.asynclayoutinflater:asynclayoutinflater:1.0.0' --> 'androidx.core:core:1.0.0'
Constraint path 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'androidx.core:core' strictly '1.0.0' because of the following reason: debugRuntimeClasspath uses version 1.0.0
Constraint path 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'androidx.core:core' strictly '1.0.0' because of the following reason: debugRuntimeClasspath uses version 1.0.0
Constraint path 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'androidx.core:core' strictly '1.0.0' because of the following reason: debugRuntimeClasspath uses version 1.0.0

> Could not resolve androidx.vectordrawable:vectordrawable:1.0.0.
Required by:
project :unimodules-react-native-adapter > androidx.vectordrawable:vectordrawable-animated:1.0.0
> Cannot find a version of 'androidx.vectordrawable:vectordrawable' that satisfies the version constraints:
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.vectordrawable:vectordrawable-animated:1.0.0' --> 'androidx.vectordrawable:vectordrawable:1.0.0'
...
> Could not resolve androidx.core:core:1.0.1.
Required by:
project :unimodules-react-native-adapter > com.facebook.react:react native:0.61.5 > androidx.appcompat:appcompat:1.0.2
> Cannot find a version of 'androidx.core:core' that satisfies the version constraints:
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.github.bumptech.glide:glide:4.9.0' --> 'androidx.fragment:fragment:1.0.0' --> 'androidx.core:core:1.0.0'
Path Dependency 'org.unimodules:unimodules-react-native-adapter:4.0.0' --> 'com.facebook.react:react native:0.61.5' --> 'androidx.appcompat:appcompat:1.0.2' --> 'androidx.core:core:1.0.1'
...and other similar dependency issues
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
* Get more help at https://help.gradle.org
BUILD FAILED in 30s
- Retha_Welch13 commented on April 3rd 20 at 17:49
@Retha_Welch13, Google error need Error: Command failed: ./gradlew app:installDebug -PreactNativeDevServerPort=8081

https://www.google.com/search?client=safari&rls=en... - carlie.Kle commented on April 3rd 20 at 17:52
@carlie.Kle, got it. Incredible. - Retha_Welch13 commented on April 3rd 20 at 17:55

Find more questions by tags ReactReact Native