Give rights to the program Transmission record file in the directory?

program for Transmission works (Ubuntu 18.04, but could not record the downloaded file in the specified setup directory.
Samba opened the folder, gave permissions 777. Using Wundows see this folder, throw files there, everything is OK. Umask =0 in the settings. But Transmission could not go to write anything.
I understand the need to give rights to the client on the record. What is the correct command? share?
April 3rd 20 at 17:36
1 answer
April 3rd 20 at 17:38
In default setup Transmission run as the user transmission.

About how you can improve.

Look, what rights to the directory in which you're trying to swing.
Stop the daemon sudo systemctl stop transmission-daemon.service
Run sudo systemctl edit transmission-daemon.service
Write something like:
[Service]
User=toilay
Group=twoarray

Change the permissions of the directory data:
sudo chown toilay:twoup -R /var/lib/transmission-daemon


Run daemon sudo systemctl start transmission-daemon.service

I currentcatalog on Filipovich create a separate user, it is indicate in the settings of the samba server.
It turns out that the fix is fine, and the files writable.
Thanks for the reply!

I'm sorry, but I don't know what my group is.
[Service]
User=toilay
Group=twoarray
Login clear.

Is it not possible in Linux to make the folder available to all users, programs, etc. Why hemorrhoids? - Maureen.Walter commented on April 3rd 20 at 17:41
@Maureen.Walter, found the group.
have done so:
sudo systemctl stop transmission-daemon.service

sudo systemctl edit transmission-daemon.service

wrote:
[Service]
User=andrei
Group=sudo

Then:
sudo chown andrei:sudo -R /var/lib/transmission-daemon

and
sudo systemctl start transmission-daemon.service

web transmishn face fell off and will not start ((

team:
systemctl status transmission-daemon

transmission-daemon.service - Transmission BitTorrent Daemon
Loaded: loaded (/lib/systemd/system/transmission-daemon.service; enabled; vendor preset: enabled)
Drop-In: /etc/systemd/system/transmission-daemon.service.d
└─override.conf
Active: active (running) since Thu 2019-12-12 16:44:53 +10; 31s ago
Main PID: 20171 (transmission-da)
Status: "Idle."
Tasks: 4 (limit: 3992)
CGroup: /system.slice/transmission-daemon.service
└─20171 /usr/bin/transmission-daemon -f --log-error

Dec 12 16:44:53 andrei-TC systemd[1]: Starting Transmission BitTorrent Daemon...
Dec 12 16:44:53 andrei-TC systemd[1]: Started Transmission BitTorrent Daemon.
Dec 12 16:44:54 andrei-TC transmission-daemon[20171]: [2019-12-12 16:44:54.803] UDP Failed to set receive buffer: requested 4194304, got 425984 (tr-udp.c:84)
Dec 12 16:44:54 andrei-TC transmission-daemon[20171]: [2019-12-12 16:44:54.803] UDP Failed to set send buffer: requested 1048576, got 425984 (tr-udp.c:95)

is there a simple command to run the client with the necessary rights? - Maureen.Walter commented on April 3rd 20 at 17:44
@Maureen.Walter, hemorrhoids this not just any. but in home use this is not understand.
to open the pack all you putting all access "sudo chmod 777 ./folder".

the group is usually given with a user name.

I have here are changes relative to the base config
/etc/systemd/system/transmission-daemon.service.d/override.conf
[Service]
User=pfg
Group=pfg
# decrement priority
Nice=10

well, a few - corine.Hilll20 commented on April 3rd 20 at 17:47

Find more questions by tags LinuxAccess rightsUbuntuBitTorrent