How to install the latest version of Filezilla?

In apt version 4 years ago. How to install a new one?
I downloaded the archive from the website, but it is not clear how to run it. Instructions 0 information


It is recommended that you use the package manager of your distribution.

If you're using GNU/Linux, you can also try using the precompiled binaries. After extracting the files to any location (location does not matter, FileZilla can detect its own installation prefix), you can start the program using the filezilla executable in the bin/ subdirectory. Please note that due to differences in distributions, the provided binaries might not work on your system.



filezilla executable in the bin/ subdirectory not working

error while loading shared libraries: libidn2.so.0: cannot open shared object file: No such file or directory


In summary, no ONE knows how to install and run the latest file from offsite. But that's what I was advised:

1. install the version published some ppa:yofel/ppa, which is 5 years
2. to install the package assembled some Mykola Ulianytskyi
3. installing with GetDeb site (which according to Wikipedia can spread malware)
4. install the snap published by the Chinese, and contramurada
5. to install from apt version 4 years ago
April 3rd 20 at 17:43
2 answers
April 3rd 20 at 17:45
Who yofel and why I have to give him access to ssh? - adaline31 commented on April 3rd 20 at 17:48
The last update in 2015 https://launchpad.net/~yofel/+archive/ubuntu/ppa

This is complete idiocy. - adaline31 commented on April 3rd 20 at 17:51
Hike you need to treat paranoia - hannah.Kemmer commented on April 3rd 20 at 17:54
@adaline31, make as written. there about access and ssh and there is no word - ursula commented on April 3rd 20 at 17:57
@ursula, well, I'm on probation. I suggest you to download the software t some other person who will have to deal with ssh. Official no? In the furnace. - adaline31 commented on April 3rd 20 at 18:00
@adaline31Exactly the best way to deal with dandruff - beheading. So You're not coming in.
In any case, good luck in finding a solution - ursula commented on April 3rd 20 at 18:03
@ursula, once again, you offered me to install Filzilla 2015 published some Bob. Thank you very much. More tips do not? - adaline31 commented on April 3rd 20 at 18:06
@ursula, you do some kind of pest. TODAY VERSION V OF TURNIPS 3.15.0.2, and you throw a link to rap from Vasi with the version 3.8.1 - adaline31 commented on April 3rd 20 at 18:09
April 3rd 20 at 17:47
First, to fix the curve of the library:
wget http://mirrors.kernel.org/ubuntu/pool/main/libi/libidn2/libidn2-0_2.0.4-1.1build2_amd64.deb
sudo dpkg-i libidn2-0_2.0.4-1.1build2_amd64.deb
sudo apt-mark hold libidn2-0


Then repeat the installation of the FileZilla package from off site.
This error disappeared, but got other dependencies. Please note anything that is not present in the official instructions FileZilla (and then ask sho about her) - adaline31 commented on April 3rd 20 at 17:50
You have something with the axle... it is not in FileZilla, I just put on a clean dev just out of the package from off site.
Write what you still got. - Suzanne_Wiegand commented on April 3rd 20 at 17:53
@Suzanne_Wiegandas set? There is not package and the archive. - adaline31 commented on April 3rd 20 at 17:56
@adaline31, try something like this https://www.computernetworkingnotes.com/linux-tuto... - Suzanne_Wiegand commented on April 3rd 20 at 17:59
I tried that for you?

1. SNEP published by the Chinese somehow, and was last updated 9 months ago.
2. apt update 4 years ago!
3. NOT WORKING as I wrote.

So what?

it is not in FileZilla, I just put on a clean dev just out of the package from off site.


as set? walking in a circle. I have something with the system, right? - adaline31 commented on April 3rd 20 at 18:02
@adaline31, you are not with the system but with a head that something is wrong. - May commented on April 3rd 20 at 18:05
@May, not weak, you have burnt - adaline31 commented on April 3rd 20 at 18:08
@adaline31, stick it in you, from his stupidity. You were given advice, and you all send. And why would you help then?
You communicate normally with people and not like a Jackal. You haven't have a bad word said until you began bychit here. - May commented on April 3rd 20 at 18:11
@May, what advice??? I will list

1. install the version published some ppa:yofel/ppa, which is 5 years
2. to install the package assembled some Mykola Ulianytskyi
3. installing with GetDeb site (which according to Wikipedia can spread malware)
4. install the snap published by the Chinese, and contramurada
5. to install from apt version 4 years ago

And a single nerd fucking didn't tell you how to install and run the fucking archive from the official website. In this case messages are already hundreds. You bitch yourself not know the campaign! And then you tell me Filzilla norms? Danunakh))) - adaline31 commented on April 3rd 20 at 18:14
@adaline31, you were given a link to a website with deb packages. I gave you a link to instructions on how to compile from source.
The fact that you can not use it is your problem. - May commented on April 3rd 20 at 18:17
@May, i.e. the only way to start FileZilla the latest version is to build from source? And now the question - why it is not written clearly on the official website? And why is there to deliberately spread outside the archive that does not run on most common Linux distribution? So a normal person would do? - adaline31 commented on April 3rd 20 at 18:20
@adaline31,
1) all satisfied with the version that the repository lies.
2) no one need file Zila
3) any file Manager works fine with FTP.

And Yes, you can't use the terminal if you can't execute two commands.
At all all works. It's just you can't do it because of ignorance. That's all. - May commented on April 3rd 20 at 18:23

Find more questions by tags LinuxUbuntu