How to make phpmyadmin c php7.3-fpm?

The server 18 ubuntu+Nginx+PHP7.3+MySQL. When you try to open phpmyadmin displays a white page. There are no errors, the logs are empty.
I understand the problem with deprecated mcrypt? How it can be fixed or is it better to look for a replacement for phpmyadmin?
April 3rd 20 at 18:31
3 answers
April 3rd 20 at 18:33
Everything works fine, Download phpmyadmin from the official site, don't forget to put php7.3-mbstring
pma 4.9.2 downloading from the office site
php7.3-mbstring is already the newest version (7.3.12-1+ubuntu18.04.1+deb.sury.org+1).


However, why is the page white. Even tried to start pma which is 4.8 on a server with php7.1+nginx and it works, but it displays a white screen. There are no errors, the only entry in the access log. - wade commented on April 3rd 20 at 18:36
@Assunta, never had a problem, check again the path - Angeline_Herman commented on April 3rd 20 at 18:39
April 3rd 20 at 18:35
I agree with TC above, all works fine even on 7.4.
In the console, write the command:
tail-f /var/log/nginx/error.log
Refresh the page and see the error right in the console.
no errors written well. Naturally I immediately go to check. - wade commented on April 3rd 20 at 18:38
@Assunta, the response code from the server when opening /phpmyadmin what? - Angie.Ledner57 commented on April 3rd 20 at 18:41
@deja4, 200 and to the source code if you go there and everything is form and all scripts, generally on the source code like all the rules. - wade commented on April 3rd 20 at 18:44
@deja4, found the cause, never would have thought to look in the console of chrome, there have been some forbideny js and css files and to blame for the "valid_referers" in nginx. For some reason this config refuses to work, even though the domain is correct and the same domain runs the pma, it is not clear how the... - wade commented on April 3rd 20 at 18:47
April 3rd 20 at 18:37
Always invite them and all will be Chiki bunches :)

Find more questions by tags PHPphpMyAdmin