When you import an optimized mesh in unity is still old, not optimized?

Obj has decided to optimize, remove triangles and vertices when imported into unity in a new obj is still not optimized mesh. Also tried fbx to import, nothing changes, while in maya everything is fine
April 3rd 20 at 18:32
3 answers
April 3rd 20 at 18:34
Doing something wrong, can not save the file in the project folder or the problem is by saving the file.
There are in fact all just works - put the new file it was updated in the project. All.

What else can I try:
to do in unity to re-import the specified file manually.
- delete Library folder from the project;
- restart PC.
Perhaps the problem is in the MagicaVoxel editor, initially the model save to obj, and then rework the mesh in Maya, actually more fill up in Unity and the mesh remains the same. Not updated the file. - Maxwell commented on April 3rd 20 at 18:37
April 3rd 20 at 18:36
Add your obj to a new project.
If not optimized - this means obj.
If optimized - the problem in the project/Unity.
Apparently the problem is in the obj, but why then in the 3D editor, all is well... - Maxwell commented on April 3rd 20 at 18:39
@Dawn.Jenkins, then he sees the setting of his display settings (settings editor) or reads them from the. obj file.
And Unity, for example, does not know how to read or interpret (or spec. did so immediately unloaded correctly optimized mesh from 3D editor). - Olga_Rolfson80 commented on April 3rd 20 at 18:42
@Casey_Wilkinson, Yes, it is. In General, it is necessary to do retopology - Maxwell commented on April 3rd 20 at 18:45
April 3rd 20 at 18:38
Maybe the optimization flags in the settings of the mesh forgot to raise?

Find more questions by tags 3ds MaxUnity Game EngineBlenderMaya