What could be the reason that the video on the website is not working?

On the website posted a video with tubau,
<div class="col-lg-4 col-md-6 col-sm-6 col-xs-12 video our_clients_video" >
 <a class="video__link" href="https://youtu.be/ESScqS_W-0k">
<picture>
 <source srcset="https://i.ytimg.com/vi_webp/ESScqS_W-0k/sddefault.webp" type="image/webp">
 <img class="video__media" src="https://i.ytimg.com/vi/ESScqS_W-0k/sddefault.jpg" alt="NASHI DOROG CLOT ABOUT US">
</picture>
</a>
 <button class="video__button" type="button" aria-label="Start video">
 <svg width="68" height="48" viewBox="0 0 68 48"><path class="video__button-shape" d="M66.52,7.74 c-0.78-2.93-2.49-5.41-5.42-6.19C55.79,.13,34,0,34,0S12.21,.13,6.9,1.55 C3.97,2.33,2.27,4.81,1.48,7.74C0.06,13.05,0,24,0,24s0.06,10.95,1.48,16.26c0.78,2.93,2.49,5.41,5.42,6.19 C12.21,47.87,34,48,34,48s21.79-0.13,27.1-1.55c2.93-0.78,4.64-3.26,5.42-6.19C67.94,34.95,68,24,68,24S67.94,13.05,66.52,7.74 z"></path><path class="video__button-icon" d="M 45,24 27,14 27, and 34"></path></svg>
</button>
 </div>

function findVideos() {
 let videos = document.querySelectorAll('.video');

 for (let i = 0; i < videos.length; i++) {
setupVideo(videos[i]);
}
}

function setupVideo(video) {
 let link = video.querySelector('.video__link');
 let media = video.querySelector('.video__media');
 let button = video.querySelector('.video__button');
 let id = parseMediaURL(media);

 video.addEventListener('click', () => {
 let iframe = createIframe(id);

link.remove();
button.remove();
video.appendChild(iframe);
});

link.removeAttribute('href');
video.classList.add('video--enabled');
}

parseMediaURL function(media) {
 let regexp = /https:\/\/i\.ytimg\.com\/vi\/([a-zA-Z0-9_-]+)\/sddefault\.jpg/i;
 let url = media.src;
 let match = url.match(regexp);

 return match[1];
}

function createIframe(id) {
 let iframe = document.createElement('iframe');

 iframe.setAttribute('allowfullscreen', ");
 iframe.setAttribute('allow', 'autoplay');
 iframe.setAttribute('src', generateURL(id));
iframe.classList.add('video__media');
iframe.classList.add('video__media2');

 return iframe;
}

function generateURL(id) {
 let query = '?rel=0&showinfo=0&autoplay=1';

 return 'https://www.youtube.com/embed/' + id + query;
}

findVideos();

On a separate page, everything works fine, but on the main error:
5dfb3aad06bf5477847849.png
Can't understand why it doesn't work, the header and footer sections on both pages is the same, as added via get_header and get_footer.
The main block "VIDEO-UGGOKI": https://newwork.com.ua/
A separate page block "NASHI DOROG CLOT ABOUT US": https://newwork.com.ua/video-clients/
April 3rd 20 at 18:40
0 answer

Find more questions by tags JavaScriptHTML