How to make strongswan with Windows 10?

Good afternoon.
There is a Centos 7 server with strongswan. Config:
#global configuration IPsec
config setup
 charondebug="cfg 2, dmn 2, ike 3, net 0"
uniqueids=no

#define new ipsec connection
conn test.net
auto=add
compress=no
type=tunnel
keyexchange=ikev2
ike=aes128-sha256-ecp256,aes256-sha384-ecp384,aes128-sha256-modp2048,aes128-sha1-modp2048,aes256-sha384-modp4096,aes256-sha256-modp4096,aes256-sha1-modp4096,aes128-sha256-modp1536,aes128-sha1-modp1536,aes256-sha384-modp2048,aes256-sha256-modp2048,aes256-sha1-modp2048,aes128-sha256-modp1024,aes128-sha1-modp1024,aes256-sha384-modp1536,aes256-sha256-modp1536,aes256-sha1-modp1536,aes256-sha384-modp1024,aes256-sha256-modp1024,aes256-sha1-modp1024!
esp=aes128gcm16-ecp256,aes256gcm16-ecp384,aes128-sha256-ecp256,aes256-sha384-ecp384,aes128-sha256-modp2048,aes128-sha1-modp2048,aes256-sha384-modp4096,aes256-sha256-modp4096,aes256-sha1-modp4096,aes128-sha256-modp1536,aes128-sha1-modp1536,aes256-sha384-modp2048,aes256-sha256-modp2048,aes256-sha1-modp2048,aes128-sha256-modp1024,aes128-sha1-modp1024,aes256-sha384-modp1536,aes256-sha256-modp1536,aes256-sha1-modp1536,aes256-sha384-modp1024,aes256-sha256-modp1024,aes256-sha1-modp1024,aes128gcm16,aes256gcm16,aes128-sha256,aes128-sha1,aes256-sha384,aes256-sha256,aes256-sha1!
fragmentation=yes
forceencaps=yes
dpdaction=clear
dpddelay=300s
rekey=no
left=%any
leftid=@test.net
leftcert=fullchain.pem
leftsendcert=always
leftsubnet=0.0.0.0/0
right=%any
rightid=%any
rightauth=eap-mschapv2
rightsourceip=10.15.1.0/24
rightdns=1.1.1.1,8.8.8.8
rightsendcert=never
 eap_identity=%identity

All the rules in iptables open.
Windows 7 connects without any problems.
Windows 10 connects, but packets only being sent, not accepted. Firewall is disabled.
What could be the problem?
April 3rd 20 at 18:50
2 answers
April 3rd 20 at 18:52
Solution
read the documentation https://wiki.strongswan.org/projects/strongswan/wi...
Most likely that will help section AES-256-CBC and MODP2048
In General, you need to install the following ipsec settings specified commandlets that are spelled out in your config strongswan.
I will add: If you can't understand, here's an article of abrowser @Wellington to help
We are in a similar configuration to live long enough - 2016 and everything works like a charm, however using eap-radius in the integration with MS AD - Andre_Rogahn9 commented on April 3rd 20 at 18:55
April 3rd 20 at 18:54
Solution
In windows 10 you need to tick the "use gateway on remote network" in tcp/ip v4
Do so.
Packets going in both directions, but when not set the metric, for example 10, then the vpn does not work correctly.
How to make all packets go through the vpn connection? - Bennett commented on April 3rd 20 at 18:57

Find more questions by tags VPNWindows