2 Mikrotik, 1 DHCP, how?

There are two Mikrotik CHR see local devices to each other via L2TP + GRE.
I personally use it for port forwarding, as the white IP has only one of these Mikrotik.
Well set up, everything is fine, but now I need entering one Mikrotik, look in the DHCP Server -> Leases what IP I need to go to the second Mikrotik and there are forwarding ports through the NAT rules.
And since they are already connected, I would like to DHCP did right the second Mikrotik with a white IP, so I configured the DHCP Server there and there was seen in Leases issued IP address.
Tried at random through a dhcp relay, tried something, tried googling it, found nothing.
Please help with this question.
April 4th 20 at 00:31
3 answers
April 4th 20 at 00:33
Well, and do it via DHCP Relay.
The DHCP server on that Microte where the external IP, relay to it set up on the second Microti.
Of course, if I have correctly understood the Concept.
So I poked like that, didn't work.
Put the DHCP server on that external IP where the gateway and the relay was the same, well, then I installed on another DHCP Relay and was trying to get IPS, but my virtual machine IPS are not issued.
Can you tell me what I could not do that? - mathilde_Schinn commented on April 4th 20 at 00:36
@mathilde_Schinn, https://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Relay - Cleta_Greenho commented on April 4th 20 at 00:39
@Cleta_Greenho, it's still not working, maybe because I have through a GRE tunnel configured, but in different ways tried, nothing works. - mathilde_Schinn commented on April 4th 20 at 00:42
@mathilde_Schinn, try using EoIP over PPTP (since you have one router with white ip), EoIP can pass through itself service packages, such as broadcasts or romon, dhcp requests should, too. - Cleta_Greenho commented on April 4th 20 at 00:45
April 4th 20 at 00:35
I think dhcp relay through vpn tunnel is not the best idea. In the event of failure of the vpn tunnel device on the remote side will cease to address.
If you still want a relay, but it doesn't work, you can see the logs to hang up the firewall on port 53 (to verify that there is traffic on the port), at least to capture traffic (tools -> traffic sniffer).
Thank you very much for the reply, I think I understand what the problem is, namely that the port 53 I have not used. I have not enabled Allow Remote Requests. I think it will solve my problem.
I will try most likely tomorrow to realize and tell you if it will work of course. - mathilde_Schinn commented on April 4th 20 at 00:38
April 4th 20 at 00:37
script which checks the second microt and as needed enables / disables relay. good examples in an Internet a heap

Find more questions by tags VPNComputer networksDHCPNetwork equipmentMikrotik