How to start VirtualBox after upgrade Win10?

After the upgrade, win, ceased to run virtualbox. Manager opens, but no Virt.machine does not start, even newly created ones.
Failed to open a session for the virtual machine test.

The virtual machine 'test' has terminated unexpectedly during startup with exit code -1073741819 (0xc0000005).
More details may be available in 'D:\ProgramFiles\Oracle\vm\test\Logs\VBoxHardening.log'.

Error code: E_FAIL (0x80004005)
Component: MachineWrap
Interface: IMachine {85632c68-b5bb-4316-a900-5eb28d3413df}


VboxHardening.log

What I was doing:
Renamed VMashina.vbox-prev VMashina.vbox,
Have deinstallirovat, and then installed vbox v6.0.12, the same vbox and vbox v 6.0.16 6.1.2.
Exported need Virt.car exports went without errors, but the import (the import process) popped up an error(not recorded).
Now temporarily copied Wirth.the drive to another computer, it works.
Help to run vbox, Wirth.the car is necessary.
April 4th 20 at 12:59
2 answers
April 4th 20 at 13:01
Solution
The first is to try to install lower version of virtual box. For example, vbox 5.2.36. If you do not help, then try these options:

More options

1. To roll back updates to Win10, if you don't need.
2. To check out if somehow the option of virtualization in BIOS E.
3. Check that the folder: "C:\Users\COMPUTER_NAME\.VirtualBox\Machines\VM_NAME\" should be VM_NAME.xml without suffixes sort of VM_NAME.xml-prev, VM_NAME.xml-tmp.
April 4th 20 at 13:03
Will help edit the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity
Enabled = 0


Didn't have the clause, created the reg_dword value to 0, rebooted, nothing has changed. - Lonnie.Jon commented on April 4th 20 at 13:06
_https://www.wintips.org/fix-virtualbox-failed-to-o... - Andrew.Rodriguez commented on April 4th 20 at 13:09
To reset the saved state is not active.
Uninstall and Re-Install VirtualBox. Also tried. - Lonnie.Jon commented on April 4th 20 at 13:12
And you can somehow 'D:\ProgramFiles\Oracle\vm\test\Logs\VBoxHardening.log' see? At least the last part of it - maybe something to see. - Andrew.Rodriguez commented on April 4th 20 at 13:15
Here's another interesting:
_https://forums.virtualbox.org/viewtopic.php?t=33196

All I did was go into the settings of each of my virtual boxes (ubuntu and xp), I disabled the Network adapter, then I was able to start the machines when the network was disabled. I shut them down, then enabled network, and they magically started working. I'm running Virtual Box 3.2.8 r64453 on Win 7 as the host (sorry linux brothers and sisters) and I'm running Ubuntu 10.04, and Win XP virtuals. I think this happened because I just updated the Win 7 host, and it updated the RealTek gigabit network hardware. I also have my Ubuntu box setup to auto start when Win 7 boots...though I have yet to test if that still works. If I don't reply again, then it worked...I'll reboot right now. Cheers!
- Andrew.Rodriguez commented on April 4th 20 at 13:18
@Andrew.Rodriguez, link to the top log on/ - Lonnie.Jon commented on April 4th 20 at 13:21
Solution:

Solution (Workaround)
For some reason when the VboxDRV.sys kernel driver gets loaded and started on boot something breaks. Now it may be my anti-virus hooking into it but I have not tested that. I did try disabling (not uninstalling) the AV with no difference. The solution I found was to delay the startup of VboxDRV service by setting its startup type to Demand. This way VboxDRV.sys will load but not start on system boot and will only start when it is needed. Conveniently, running VirtualBox VboxDRV will trigger the service to start and by that time, the boot process should be complete and everything works without any issues (opening VMs without the error above).

I found this fix works best if done in this order:

Completely uninstall any currently installed VirtualBox
Restart the computer
Install the latest version of VirtualBox
After the install completes do not restart the computer
Open the registry editor. Start > Run > regedit
Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VBoxDrv
Edit the key called Start. Change it's value from 1 to 3
Close the registry editor and restart your computer. After your computer restarts you should be able to use VirtualBox without any issues.

Upon restart you can confirm VBoxDrv did not start on boot by opening command prompt > type sc query vboxdrv > under STATE it should say STOPPED

Hope this helps someone. I know it's not a proper fix but it's the best one so far for people where reinstalling Windows or uninstalling their anti-virus is not an option.


Here. - Andrew.Rodriguez commented on April 4th 20 at 13:24
5e26b855e2fc4163337941.png

Fixed 1 in 3 got this error, and her old popping up. - Lonnie.Jon commented on April 4th 20 at 13:27
After the specified in the message action has something changed? sc query vboxdrv and restart. - Andrew.Rodriguez commented on April 4th 20 at 13:30
>sc query vboxdrv

SERVICE_NAME: vboxdrv
TYPE : 1 KERNEL_DRIVER
STATE : 1 STOPPED
WIN32_EXIT_CODE : 1077 (0x435)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0

Restart
Appeared only new message that above, nothing else has changed. - Lonnie.Jon commented on April 4th 20 at 13:33
Maxim Ярошевич@Andrew.Rodriguez Thanks for the support, helped the transition to an older version of vbox 5.2.36 - Lonnie.Jon commented on April 4th 20 at 13:36
@Lonnie.Jon, it is Strange, the latest version of VB installed on multiple computers - no problems, I would still try to poudalyat to ostanavlivat VB with cleaning everything possible. - Andrew.Rodriguez commented on April 4th 20 at 13:39

Find more questions by tags VirtualBoxWindows