On Ubunru 18 stopped working spawn-fcgi, why?

16 Ubuntu Munin worked perfectly and drew all the graphics
now I shifted to Ubuntu 18
Munin configured but in Ubuntu 16 spawn-fcgi will not start and crashes before start, (he paints large pictures of graphs)
The team that worked on 16 Ubuntu
spawn-fcgi -s /var/run/munin/fcgi-graph.sock -U www-data -u www-data -g www-data /usr/lib/munin/cgi/munin-cgi-graph


The console output
:~# spawn-fcgi -s /var/run/munin/fcgi-graph.sock -U www-data -u www-data -g www-data /usr/lib/munin/cgi/munin-cgi-graph
spawn-fcgi: child exited with: 2


Prompt where to dig?
April 4th 20 at 13:15
1 answer
April 4th 20 at 13:17
Solution
https://stackoverflow.com/questions/16306210/spawn...
says
#define EPERM 1 /* Operation not permitted */
#define ENOENT 2 /* No such file or directory */

check that /usr/lib/munin/cgi/munin-cgi-graph is

file /usr/lib/munin/cgi/munin-cgi-graph
/usr/lib/munin/cgi/munin-cgi-graph: Perl script text executable

and runs
Yes, the file is there, even I tried to run it :)
in response to this
/usr/lib/munin/cgi/munin-cgi-graph
Can't locate CGI/Fast.pm in @INC (you may need to install the CGI::Fast module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1 /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/lib/munin/cgi/munin-cgi-graph line 36.
BEGIN failed--compilation aborted at /usr/lib/munin/cgi/munin-cgi-graph line 36.
- Llewellyn_Kozey52 commented on April 4th 20 at 13:20
@Llewellyn_Kozey52 discover CPAN
https://www.cpan.org/
https://wiki.dieg.info/cpan

(don't forget to mark as solution pita - Melba.Cartwright commented on April 4th 20 at 13:23
@Melba.Cartwright, thanks for the tip!
PS wouldn't start - but okay, we'll find ways around :) - Llewellyn_Kozey52 commented on April 4th 20 at 13:26

Find more questions by tags PerlHostingMunin