Why eslint does not correct the extra padding?

Good day! Please help to understand why eslint does not correct the excess withdrawal?
How to fix it?
5e28032f3253f365866676.png
Project react/typescript.

.eslintrc.json
{
"extends":[
"eslint:recommended",
"plugin:@typescript-eslint/eslint-recommended",
"plugin:@typescript-eslint/recommended"
],
"parser":"@typescript-eslint/parser",
"parserOptions":{
"ecmaVersion":2018,
 "sourceType": "module",
 "ecmaFeatures": {
 "jsx": true
}
},
"plugins":[
"@typescript-eslint"
],
"rules":{
}
}


I would be very, very grateful for the help!
April 4th 20 at 13:18
1 answer
April 4th 20 at 13:20
Solution
Probably need to add in settings here is the rule:
https://eslint.org/docs/rules/no-multiple-empty-lines
Yes, thank you)
but as this is to fix?
5e283803013be992606324.png

plus the fact that constants with the same names? - bryce commented on April 4th 20 at 13:23
@bryce, I see you have used prettier? Apparently, you need to make friends with eslint if it is not podruzhen and everything is working as it should.
The first thing that managed to Google on the subject: https://thomlom.dev/setup-eslint-prettier-react/ - Tamia83 commented on April 4th 20 at 13:26
@Tamia83, I still have the typescript and webpack. Apparently the main problem with typescript - bryce commented on April 4th 20 at 13:29
@bryce, webpack is not a problem, typescript, Yes.
There is such a manual) - Tamia83 commented on April 4th 20 at 13:32
@bryce, if helped, mark the solution please :) - Tamia83 commented on April 4th 20 at 13:35

Find more questions by tags JavaScriptLinter