Why can't open folder in yii2 web browser?

Good afternoon.
Started to learn yii advanced.
Work in Ubuntu.
As a server I use apache2 installed via laradock.

Just installed yii, nothing in the files have not changed, and when I pass the path frontend/web/ , I get the message that the page was found.

It may be the case in apache?

Here are his settings.

And in /etc/hosts is also prescribed elisdn.loc

Thanks in advance for the tip.
April 4th 20 at 13:23
1 answer
April 4th 20 at 13:25
Most likely, You need to .htaccess, which must be located in the project root, set the explicit path to the web, here's an example
Options +FollowSymLinks
IndexIgnore */*
RewriteEngine on

RewriteCond %{REQUEST_URI} !^/(web)
RewriteRule ^assets/(.*)$ /web/assets/$1 [L]
RewriteRule ^favicon.ico$ /web/favicon.ico$1 [L]
RewriteRule ^css/(.*)$ web/css/$1 [L]
RewriteRule ^js/(.*)$ web/js/$1 [L]
RewriteRule ^img/(.*)$ web/img/$1 [L]
RewriteRule ^files/(.*)$ web/files/$1 [L]
RewriteRule ^fonts/(.*)$ web/fonts/$1 [L]
RewriteRule (.*) /web/$1

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /web/index.php
Thank you, worked. - Jada.Kuhn36 commented on April 4th 20 at 13:28
@Jada.Kuhn36, this time the reading helped, in others it may not help-you need to explicitly specify the errors, screenshots, and text - orpha59 commented on April 4th 20 at 13:31
@orpha59Thanks, I realized my mistake, corrected)) - Jada.Kuhn36 commented on April 4th 20 at 13:34

Find more questions by tags Yii