Error node-gyp if the module is installed node js — MSBUILD: error MSB6001?

Error occurs when installing any module that uses node-gyp

I think the problem is VCBuild.exe

In the global PATH variable is the path to Python, as well as to npm

What could be the problem? All additional libraries have been installed in Microsoft Visual Studio

error M:\YandexDisk\YandexDisk\Desktop App\project\bluecontroll-desktop-app-electron\node_modules\node-bluetooth: Command failed.
 Exit code: 1
 Command: node-gyp configure build
Arguments:
 Directory: M:\YandexDisk\YandexDisk\Desktop App\project\bluecontroll-desktop-app-electron\node_modules\node-bluetooth
Output:
 M:\YandexDisk\YandexDisk\Desktop App\project\bluecontroll-desktop-app-electron\node_modules\node-bluetooth>if not defined npm_config_node_gyp (node "M:\Program Files\node\node_modules\npm\bin\node-gyp-bin\\..\
 ..\node_modules\node-gyp\bin\node-gyp.js" configure build ) else (node "" configure build )
 gyp info it worked if it ends with ok
 gyp info using node-gyp@3.6.2
 gyp info using node@8.9.2 | win32 | x64
 gyp info spawn M:\Android\Python\python.exe
 gyp info spawn args [ 'M:\\Program Files\\node\\node_modules\\npm\\node_modules\\node-gyp\\gyp\\gyp_main.py',
 gyp info spawn args 'binding.gyp',
 gyp info spawn args '-f',
 gyp info spawn args 'msvs',
 gyp info spawn args '-G',
 gyp info spawn args 'msvs_version=auto',
 gyp info spawn args '-I',
 gyp info spawn args 'M:\\YandexDisk\\YandexDisk\\Desktop App\\project\\bluecontroll-desktop-app-electron\\node_modules\\node-bluetooth\\build\\config.gypi',
 gyp info spawn args '-I',
 gyp info spawn args 'M:\\Program Files\\node\\node_modules\\npm\\node_modules\\node-gyp\\addon.gypi',
 gyp info spawn args '-I',
 gyp info spawn args 'C:\\Users\\Fox\\.node-gyp\\8.9.2\\include\\node\\common.gypi',
 gyp info spawn args '-Dlibrary=shared_library',
 gyp info spawn args '-Dvisibility=default',
 gyp info spawn args '-Dnode_root_dir=C:\\Users\\Fox\\.node-gyp\\8.9.2',
 gyp info spawn args '-Dnode_gyp_dir=M:\Program Files\\node\\node_modules\\npm\\node_modules\\node-gyp',
 gyp info spawn args '-Dnode_lib_file=C:\\Users\\Fox\\.node-gyp\\8.9.2\\<(target_arch)\\node.lib',
 gyp info spawn args '-Dmodule_root_dir=M:\\YandexDisk\\YandexDisk\\App Desktop\\project\\bluecontroll-desktop-app-electron\\node_modules\\node-bluetooth',
 gyp info spawn args '-Dnode_engine=v8',
 gyp info spawn args '--depth=.',
 gyp info spawn args '--no-parallel',
 gyp info spawn args '--generator-output',
 gyp info spawn args 'M:\\YandexDisk\\YandexDisk\\DesktopApp\\project\\bluecontroll-desctop-app-electron\\node_modules\\node-bluetooth\\build',
 gyp info spawn args '-Goutput_dir=.' ]
 gyp info spawn C:\Program Files (x86)\MSBuild\14.0\bin\msbuild.exe
 gyp info spawn args [ 'build/binding.sln',
 gyp info spawn args '/clp:Verbosity=minimal',
 gyp info spawn args '/nologo',
 gyp info spawn args '/p:Configuration=Release;Platform=x64' ]
 ���ઠ �஥�⮢ � �⮬ �襭�� �� ������. �⮡� ������� ��ࠫ������ ᡮ��, ������� ��ࠬ��� "/m".
 MSBUILD : error MSB6001: �������⨬� ���� ��������� ��ப� ��� "VCBuild.exe". ������� 㦥 ��������. ���� � ᫮���: "npm_config_python" ������ 塞� ����: 'npm_config_PYTHON' [M:\YandexDisk\YandexDisk\Desktop App\project\
bluecontroll-desktop-app-electron\node_modules\node-bluetooth\build\binding.sln]
 gyp ERR! build error
 gyp ERR! stack Error: `C:\Program Files (x86)\MSBuild\14.0\bin\msbuild.exe` failed with exit code: 1
 gyp ERR! stack at ChildProcess.onExit (M:\Program Files\node\node_modules\npm\node_modules\node-gyp\lib\build.js:258:23)
 gyp ERR! stack at emitTwo (events.js:126:13)
 gyp ERR! stack at ChildProcess.emit (events.js:214:7)
 gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
 gyp ERR! System Windows_NT 6.1.7601
 gyp ERR! command "M:\\Program Files\\node\\node.exe" "M:\\Program Files\\node\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "configure" "build"
 gyp ERR! cwd M:\YandexDisk\YandexDisk\Desktop App\project\bluecontroll-desktop-app-electron\node_modules\node-bluetooth
June 10th 19 at 14:24
1 answer
June 10th 19 at 14:26
In the past on windows 7 need more .NET Framework 4.5.1

In any case, please go here https://github.com/nodejs/node-gyp choose your version in the tags and read the README, install, 2 points check with what you have, in most cases helps

Find more questions by tags npmVisual StudioNode.js