How to pass a function of the DHCP server the router?

There are Gpon-Nokia modem(Alcatel Lucent), gives the ip to wired and wireless clients, not enough fast. Is the router Tp-Link Archer C7. Connect them LAN. Wired clients hang on Tp-Link. Disable Nokia on and turn on the Tp-Link DHCP server. All devices in the network, but no Internet. Please tell me what to check?
April 7th 20 at 11:58
3 answers
April 7th 20 at 12:00
Solution
1. Cable from Nokia plug to the blue port of the router, not yellow;
2. Disable DHCP on the Nokia didn't have to return;
3. You need to ensure that network from Nokia and LAN on the Tp-Link is different (e.g., 192.168.0.0/24, the other 192.168.1.0/24), if not, then change one of the networks (typically DHCP settings are changing automatically, but it is also better to check).
why would he double NAT ? - Kelly.Bradtke94 commented on April 7th 20 at 12:03
@Althea_Jaskolski, too true :) but nothing to do, so the task from the author.
Single NAT, consider two options:
1) NAT only on TP-Link. But, the author writes:
There are Gpon-Nokia modem(Alcatel Lucent), gives the ip to wired and wireless clients

Wired clients hang on Tp-Link.

So wireless is left on the Nokia, and they need NAT and DHCP, I came to a contradiction.
2) NAT only for Nokia. Two more options:
2.1) TP-Link as a router, the relationship with Nokia through WAN. In this case you need NAT on TP-Link because Nokia wired clients will be from a "foreign network". This can be circumvented, if the interface of Nokia is not much reduced, and allows you to manually add routes (and moreover, if TP-Link allows you to turn off NAT (and not all routers even allow)). Default not really expect such a possibility.
2.2) TP-Link as a bridge. In this case we get two conflicting DHCP servers in one broadcast domain, came to the contradiction.

But if you're lucky twice in paragraph 2.1, you are right, it makes sense to do one NAT. - Brandon_McDermott commented on April 7th 20 at 12:06
@Bradley_Tromp96, You are mistaken, any device in one broadcast domain can be the DHCP server and clients connected via wifi to nokia need no your DHCP.
The author almost did everything right, he just DHCP you need to configure. And how to do it I have already answered. - Kelly.Bradtke94 commented on April 7th 20 at 12:09
@Althea_Jaskolski, Yes, exactly. I fixated on the fact that in previous versions needed the DHCP on the Nokia, and missed that in version 2.2 it is not needed. Thank you for your perseverance, you're right. - Brandon_McDermott commented on April 7th 20 at 12:12
2. Disable DHCP on the Nokia didn't have to return;

Now, DHCP on Tp-link, and everything else. The main point was sticking in Wan) and then it's easier, shame I didn't know it, the office has always been stuck in the stupid LAN LAN and worked. And Yes, the important thing to
network Nokia and LAN on Tp-Link different
.
Then configure in the wan settings: static ip, auto-detect and you're done!
Thank you all! - greyson.Upton81 commented on April 7th 20 at 12:15
April 7th 20 at 12:02
Set the default gateway for the Tp-Linka, it needs to be router Nokia (finger in the air, but suddenly work).
April 7th 20 at 12:04
In the settings, DHCP on TPlink default gateway should be the ip address of the Nokia (and the same network) at nokia, dhcp must be turned off (also don't forget about DNS or ip white DNS (Google, provider p) or ip nokia

Find more questions by tags DHCPComputer networksSystem administration