What do you do in your applications if?

API backend has changed, and the old version of the application not loads the required data and not all users have updated to the latest version?
When you run the application show a screen saying that there was a new version and require it to be installed making it impossible to use the old version?
April 7th 20 at 15:31
2 answers
April 7th 20 at 15:33
Solution
Personally we have in the API request from the application, you specify the version of API, on the server support the last three versions, so the update is completely smooth.
Oh, thank you - Carlie_Hop commented on April 7th 20 at 15:36
April 7th 20 at 15:35
Solution
You can also use the Core library from Google Play, which allows you to force an update of users to the new version:
https://developer.android.com/reference/com/google...
good thing, thanks! - Carlie_Hop commented on April 7th 20 at 15:38
Full guide: https://developer.android.com/guide/playcore/in-ap... - hubert.Veum69 commented on April 7th 20 at 15:41

Find more questions by tags AndroidiOSMobile development