How to enable spoil 9050 and 9051 TOR?

i.imgur.com/tGx5dev.png

Installed tor but after rebooting the PC do not see port 9050
how do I activate it?
April 7th 20 at 15:37
2 answers
April 7th 20 at 15:39
1. Show the config.
2. See that in the logs.
what kind of config to show? - alvis86 commented on April 7th 20 at 15:42
all I had to do.
sudo apt install tor
sudo sed -i 's/#ControlPort/ControlPort/g' /etc/tor/torrc
sudo systemctl start tor

the result:
vagrant@localhost:~$ sudo systemctl restart tor
vagrant@localhost:~$ sudo lsof -i-P-n
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
systemd-r 421 systemd-resolve 12u IPv4 14829 0t0 UDP 127.0.0.53:53
systemd-r 421 systemd-resolve 13u IPv4 0t0 TCP 14830 127.0.0.53:53 (LISTEN)
478 sshd root 3u IPv4 17310 0t0 TCP *:22 (LISTEN)
478 sshd root 4u IPv6 17321 0t0 TCP *:22 (LISTEN)
systemd-n 873 systemd-network 20632 20u IPv4 0t0 UDP 192.168.121.242:68
876 sshd root 3u IPv4 0t0 TCP 20742 192.168.121.242:22->192.168.121.1:54140 (ESTABLISHED)
907 vagrant sshd 3u IPv4 0t0 TCP 20742 192.168.121.242:22->192.168.121.1:54140 (ESTABLISHED)
1312 tor debian-tor 8u IPv4 25560 0t0 TCP 127.0.0.1:9050 (LISTEN)
1312 tor debian-tor 25561 9u IPv4 0t0 TCP 127.0.0.1:9051 (LISTEN)
1312 tor debian-tor 14u IPv4 0t0 TCP 25581 192.168.121.242:58238->144.76.96.6:9001 (ESTABLISHED)
- cornelius_Mraz commented on April 7th 20 at 15:45
@Beula.Co, config Torah, you are trying to run? on your skrite one of the ports listening, second to none. So the service works. 9051 - controlport, you can enable it yourself in the config. - cornelius_Mraz commented on April 7th 20 at 15:48
@jeanie, so 9051 works for me but no 9050
alex@alex-HP-ZBook-15:~$ netstat-lnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State 
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 
tcp 0 0 127.0.0.1:63342 0.0.0.0:* LISTEN 
tcp 0 0 127.0.0.1:5939 0.0.0.0:* LISTEN 
tcp 0 0 127.0.0.53:53 0.0.0.0:* LISTEN 
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 
tcp 0 0 127.0.0.1:9051 0.0.0.0:* LISTEN 
tcp 0 0 127.0.0.1:6942 0.0.0.0:* LISTEN 
tcp6 0 0 :::80 :::* LISTEN 
tcp6 0 0 :::22 :::* LISTEN 
tcp6 0 0 ::1:631 :::* LISTEN
- alvis86 commented on April 7th 20 at 15:51
@jeanie, in the file my /etc/tor/torrc
CookieAuthentication 0
ControlPort 9051
- alvis86 commented on April 7th 20 at 15:54
See /var/log/syslog , maybe there is something.
Try to register SOCKSPort 9050 in the config explicitly change the port for a change. - cornelius_Mraz commented on April 7th 20 at 15:57
@jeanie, here is the log
i.imgur.com/q3FSHTu.png - alvis86 commented on April 7th 20 at 16:00
Do you really not see the problem?
You ports are already occupied, so the service cannot prividitsya to them.
Stop the service for security sudo systemctl stop tor
Check who is holding the port with sudo netstat-lnp | grep 9051
Kill unnecessary process, understand who it was.
Try to run it again. - cornelius_Mraz commented on April 7th 20 at 16:03
@jeanie, here
$ sudo netstat-lnp | grep 9051
tcp 0 0 127.0.0.1:9051 0.0.0.0:* LISTEN 1120/privoxy
- alvis86 commented on April 7th 20 at 16:06
April 7th 20 at 15:41
Make in the console: service tor start
And to automatically start at boot: systemctl enable tor
Made : service tor start
port again no - alvis86 commented on April 7th 20 at 15:44

Find more questions by tags LinuxTor