How to remove the internal padding in the code when saving to VSCode?

Good evening. There is a problem. Writing some piece of code React-app and pressing Ctrl+S appear padding:
5e4c3600b7645628023728.jpeg

What error appears:
5e4c3615ae8f4059950654.jpeg

Erasing the margins VSCode ceases to swear. But after saving the changes still appear indented. Tell me how to remove them. I looked in the settings. But I found nothing. Maybe just not out there watching.
April 7th 20 at 15:46
1 answer
April 7th 20 at 15:48
The question is canceled. Everything is solved by configuring the syntax. (if I understand correctly). Click on the name under the displayed arrow.

5e4c3be6d96d4155952343.jpeg

Choose "set up for sopostavlenija files "JS".. Select the desired language and everything will work.

Find more questions by tags Visual Studio Code