Nginx is not raised after upgrading centos?

Updated, now Knicks is. Writes:

[root@sev ~]# /etc/init.d/nginx restart
nginx: [emerg] module "/usr/lib/nginx/modules/ngx_http_geoip_module.so" version 1010002 instead of 1013005 in /usr/share/nginx/modules/mod-http-geoip.conf:1
nginx: configuration file /etc/nginx/nginx.conf test failed
June 10th 19 at 14:48
4 answers
June 10th 19 at 14:50
Well, there are written loyalty modules do not match, the module should also be updated
I understood it, did not understand how to do it. - mabelle_Wyman commented on June 10th 19 at 14:53
well depends on how you put it
Usually yum update - Eulalia22 commented on June 10th 19 at 14:56
set standard, typed update and send the list of new things, and then got out of the canoe. Updated again as fully and purely the Knicks tried, in the end the bolt. - mabelle_Wyman commented on June 10th 19 at 14:59
if you do not understand what is happening, just don't use this module - Eulalia22 commented on June 10th 19 at 15:02
and , again, the question is how to do it))) - mabelle_Wyman commented on June 10th 19 at 15:05
well it says in what file and what line you connect it - Eulalia22 commented on June 10th 19 at 15:08
alas, I salmeterol, but the Knicks started all the other modules too in turn to throw in failed. - mabelle_Wyman commented on June 10th 19 at 15:11
well unplug from do not really understand why they tell you , you probably put something with your hands and not via yum - Eulalia22 commented on June 10th 19 at 15:14
so , no, everything is standard. The GM modules, too, such default, if disabled as far as I understand some of the functions will fly. - mabelle_Wyman commented on June 10th 19 at 15:17
well can't be them standard you have the way of ngenxa as in Praha and is tsentos, it's right to say anything standard you have there - Eulalia22 commented on June 10th 19 at 15:20
in Ubuntu/Debian the same way - Brady31 commented on June 10th 19 at 15:23
Yes nichrome there is not the same way, configs in etc to do Ana in uzr - Eulalia22 commented on June 10th 19 at 15:26
June 10th 19 at 14:52
sudo yum update nginx-module-geoip
[root@sev ~]# sudo yum update nginx-module-geoip
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
* atomic: www4.atomicorp.com
* base: mirror.corbina.net
* epel: www.nic.funet.fi
* extras: mirror.corbina.net
* updates: mirror.corbina.net
Package(s) nginx-module-geoip available, but not installed.
No Packages marked for Update
- mabelle_Wyman commented on June 10th 19 at 14:55
and you with a rap and put nginx? - Eulalia22 commented on June 10th 19 at 14:58
try to assume that from EPEL.
Try updating from a different repository.
Have a Broken Repo versions are usually fresher.
sudo yum-y install yum-utils
sudo yum-config-manager --add-repo <a href="https://brouken.com/brouken.repo</code></pre><br/><br/>">https://brouken.com/brouken.repo</a>


If you use the EPEL repository, then you need to specify that it is not necessary to take with Nginx:

sudo yum-config-manager --save --setopt=epel.exclude=nginx*
- mabelle_Wyman commented on June 10th 19 at 15:01
June 10th 19 at 14:54
Hi,

Easier to reinstall nginx.
Or need more information:
nginx -t
inside configs, etc.
June 10th 19 at 14:56
Disable geo IP generally run the website and apaj module
well, or
https://jaranguda.com/nginx-error-geoip-version-10...
In General, the information on the Internet a lot.

Find more questions by tags NginxCentOS