How to make friends c SMTP from Yandex?

I wanted to set alerts via mail Yandex, but he began to swear:
Swift_TransportException
Failed to authenticate on SMTP server with username "xxx@yandex.ru" using 3 possible authenticators

Options ordered the following (project of Yii2):
'smtp_host' => 'smtp.yandex.ru',
'smtp_port' => '587',
'smtp_encryption' => 'tls',
'username' => 'xxx@yandex.ru',
'password' => 'xxx',

What I can do here? Not the first time a pain in the ass with this theme occurs(
June 10th 19 at 15:12
4 answers
June 10th 19 at 15:14
username without @yandex.ru?
if it were so easy) but no, alas) - Jessyca.McDermott commented on June 10th 19 at 15:17
,
a project on Yii2

and just need the prefix smtp_?
try this:
'host' => 'smtp.yandex.ru',
'port' => '587',
'encryption' => 'tls',
'username' => 'xxx@yandex.ru',
'password' => 'xxx',
- Mohamed_Lind75 commented on June 10th 19 at 15:20
no))
'mailer' => [
 'class' => 'yii\swiftmailer\Mailer',
 // send all mails to a file by default. You have to set
 // 'useFileTransport' to false and configure a transport
 // for the mailer to send real emails.
 'useFileTransport' => false,
 'transport' => [
 'class' => 'Swift_SmtpTransport',
 'host' => $params['smtp_host'],
 'port' => $params['smtp_port'],
 'encryption' => $params['smtp_encryption'],
 'username' => $params['username'],
 'password' => $params['password']
]
 ],
- Jessyca.McDermott commented on June 10th 19 at 15:23
,
OK, and do you call?
That is where setFrom and setTo?

Also check the value of 'adminEmail' in the settings...

If you put 'useFileTransport' => true, in the letter which values of the sender, from, subject? outdebate everything is fine! :) - Mohamed_Lind75 commented on June 10th 19 at 15:26
I have Yandex normal send - ines_Sta commented on June 10th 19 at 15:29
I have way too normally, but with a different address. And the difference in the settings I still haven't found(( - Jessyca.McDermott commented on June 10th 19 at 15:32
the fact is that in the code no problem as such - it was done right, because one *yandex address, the mailing passes, and with no other. But I don't understand what is wrong in the settings - Jessyca.McDermott commented on June 10th 19 at 15:35
so can too many emails per day sent and it locked just? - ines_Sta commented on June 10th 19 at 15:38
no , it's fresh. Registered today and tried to test - Jessyca.McDermott commented on June 10th 19 at 15:41
and the box itself went? - Mohamed_Lind75 commented on June 10th 19 at 15:44
If you are setting up getting mail from the box "login@yandex.ru", your username is the part of the address before the "@"sign.
Taken here - Damien_Haley commented on June 10th 19 at 15:47
now, have struggled with this same error. Helped bind a phone number to the box. - Gunner commented on June 10th 19 at 15:50
heh, thank you) still need to guess) - Jessyca.McDermott commented on June 10th 19 at 15:53
and the first time I Regal the ACC three weeks ago, everything was OK. Threw it in config for 5 cars, a few days later the emails stopped coming and ACC I get blocked with the reason, they say you have been hacked... And from the second, the emails did not leave immediately, yet not tied to the phone number. - Gunner commented on June 10th 19 at 15:56
June 10th 19 at 15:16
with ssl encryption and smtp_port 465 the same error?
Yes - Jessyca.McDermott commented on June 10th 19 at 15:19
June 10th 19 at 15:18
If the box svejeprigotovlenny, sending may not be held until verification of the phone number for this mailbox
June 10th 19 at 15:20
The sender's address when sending letters must be the same as the mailbox address from which you log in via smtp

Find more questions by tags YandexSMTP